On 09/29, Rajendra Nayak wrote: > Add a helper API that will allow clk providers to turn their clk_hw > structures into struct clk pointer. > Did I suggest this? > Signed-off-by: Rajendra Nayak <rnayak@xxxxxxxxxxxxxx> > --- > drivers/clk/clk.c | 6 ++++++ > include/linux/clk-provider.h | 1 + > 2 files changed, 7 insertions(+) > > diff --git a/drivers/clk/clk.c b/drivers/clk/clk.c > index 820a939..a084132 100644 > --- a/drivers/clk/clk.c > +++ b/drivers/clk/clk.c > @@ -186,6 +186,12 @@ const char *clk_hw_get_name(const struct clk_hw *hw) > } > EXPORT_SYMBOL_GPL(clk_hw_get_name); > > +struct clk *clk_hw_get_clk(const struct clk_hw *hw) > +{ > + return hw->clk; I'd prefer we actually went through all the work and actually allocated another clk structure here. We can add another string or two for the dev_id and con_id too for debug/accouting purposes. The hw->clk is sort of a remnant of the clk_core introduction. I can't recall the exact plan (i.e. I should write it down somewhere once I do) but I think we want to get rid of hw->clk and have everyone use clk_hw_get_clk() instead. Then for traversals from the clk_hw pointer to a clk pointer are very clear. -- Qualcomm Innovation Center, Inc. is a member of Code Aurora Forum, a Linux Foundation Collaborative Project -- To unsubscribe from this list: send the line "unsubscribe linux-arm-msm" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html