Re: [PATCH v1] dt-bindings: qcom: geni-se: Rename qcom,geni-se.yaml to qcom,geni-se-qup.yaml

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On 25/02/2025 10:33, Viken Dadhaniya wrote:
> 
> 
> On 2/24/2025 6:59 PM, Krzysztof Kozlowski wrote:
>> On 24/02/2025 14:25, Viken Dadhaniya wrote:
>>>
>>>
>>> On 2/24/2025 3:48 PM, Krzysztof Kozlowski wrote:
>>>> On 24/02/2025 09:47, Viken Dadhaniya wrote:
>>>>>
>>>>>
>>>>> On 2/21/2025 5:05 PM, Krzysztof Kozlowski wrote:
>>>>>> On 21/02/2025 09:54, Viken Dadhaniya wrote:
>>>>>>> The qcom,geni-se.yaml file describes the Qualcomm Universal Peripheral
>>>>>>> (QUP) wrapper and the common entities required by QUP to run any Serial
>>>>>>> Engine (SE) as I2C, SPI, UART, or I3C protocol.
>>>>>>>
>>>>>>> Rename qcom,geni-se.yaml to qcom,geni-se-qup.yaml to better reflect its
>>>>>>> association with QUP (Qualcomm Universal Peripheral) and the compatible
>>>>>>> string.
>>>>>>>
>>>>>>> Signed-off-by: Viken Dadhaniya <quic_vdadhani@xxxxxxxxxxx>
>>>>>>> ---
>>>>>>>     .../soc/qcom/{qcom,geni-se.yaml => qcom,geni-se-qup.yaml}       | 2 +-
>>>>>>>     1 file changed, 1 insertion(+), 1 deletion(-)
>>>>>>>     rename Documentation/devicetree/bindings/soc/qcom/{qcom,geni-se.yaml => qcom,geni-se-qup.yaml} (98%)
>>>>>>>
>>>>>>
>>>>>> That's just churn for no real gain. Not even tested churn.
>>>>>
>>>>> That's just churn for no real gain.
>>>>>
>>>>> We made this change based on below plan, we think this will be helpful.
>>>>>
>>>>> 1. Rename qcom,geni-se.yaml to qcom,geni-se-qup.yaml. Reason at 2 below.
>>>>
>>>> There is no reason 2 at this point. You split your patchsets
>>>> incorrectly. At this point this is churn, without gain. No users of this
>>>> rename, no benefits.
>>>>
>>>>> 2. Create qcom,geni-se.yaml with shared properties for SE-protocol (spi,
>>>>> i2c, uart) nodes. This will be helpful for the shared schema in the
>>>>> ongoing changes
>>>>
>>>> Then post it, instead of sending something which makes no sense on its own.
>>>
>>> Should I include this change in v3 of the following serial patch?
>>>
>>> https://lore.kernel.org/linux-arm-msm/f090d637-1ef1-4967-b5bc-6bfce3d7130e@xxxxxxxxxx/T/
>>>
>>> I hope the approach below is fine for you:
>>>
>>> 1. Rename qcom,geni-se.yaml to qcom,geni-se-qup.yaml.
>>
>> I still do not see any need nor justification for above.
>>
>>> 2. Create qcom,geni-se.yaml with shared properties for SE-protocol (i2c,
>>> spi, uart) nodes.
>>
>> Look how other common qcom schemas are named :/
>>
> 
> Yes, but we need to get agreement on whether we can create it or not. I 

That's not how upstream works.
https://www.goodreads.com/quotes/437173-talk-is-cheap-show-me-the-code

I don't have time to discuss imaginary future work which might happen or
might not. Send complete work.


> found a few commonly used files:
> 
> - /pci/qcom,pcie-common.yaml
> - /pinctrl/qcom,tlmm-common.yaml

so common suffix - geni-se-common... or geni-se-qup-props to mimic
peripheral properties.

Best regards,
Krzysztof




[Index of Archives]     [Linux ARM Kernel]     [Linux ARM]     [Linux Omap]     [Fedora ARM]     [Linux for Sparc]     [IETF Annouce]     [Security]     [Bugtraq]     [Linux MIPS]     [ECOS]     [Asterisk Internet PBX]     [Linux API]

  Powered by Linux