On Tue, Sep 24, 2024 at 05:14:49PM GMT, Jessica Zhang wrote: > > > On 9/24/2024 4:41 PM, Dmitry Baryshkov wrote: > > On Tue, Sep 24, 2024 at 03:59:32PM GMT, Jessica Zhang wrote: > > > Cache the CWB block mask in the DPU virtual encoder and configure CWB > > > according to the CWB block mask within the writeback phys encoder > > > > > > Signed-off-by: Jessica Zhang <quic_jesszhan@xxxxxxxxxxx> > > > --- > > > drivers/gpu/drm/msm/disp/dpu1/dpu_encoder.c | 83 +++++++++++++++++++++- > > > drivers/gpu/drm/msm/disp/dpu1/dpu_encoder_phys.h | 16 ++++- > > > .../gpu/drm/msm/disp/dpu1/dpu_encoder_phys_wb.c | 4 +- > > > 3 files changed, 100 insertions(+), 3 deletions(-) > > > > > > @@ -2557,6 +2630,14 @@ enum dpu_intf_mode dpu_encoder_get_intf_mode(struct drm_encoder *encoder) > > > return INTF_MODE_NONE; > > > } > > > +unsigned int dpu_encoder_helper_get_cwb(struct dpu_encoder_phys *phys_enc) > > > > it's called get_cwb, but it returns a mask? > > I'd based this function off of dpu_encoder_helper_get_dsc(), but I can > rename this to *_get_cwb_mask() instead Yes, please. > > > > > > +{ > > > + struct drm_encoder *encoder = phys_enc->parent; > > > + struct dpu_encoder_virt *dpu_enc = to_dpu_encoder_virt(encoder); > > > + > > > + return dpu_enc->cwb_mask; > > > +} > > > + > > > unsigned int dpu_encoder_helper_get_dsc(struct dpu_encoder_phys *phys_enc) > > > { > > > struct drm_encoder *encoder = phys_enc->parent; -- With best wishes Dmitry