Hi Suraj > [PATCH net-next v5 3/3] net: stmmac: Add driver support for DWMAC5 safety IRQ support On Mon, Dec 11, 2023 at 01:31:53PM +0530, Suraj Jaiswal wrote: > Add IRQ support to listen HW safety IRQ like ECC(error > correction code), DPP(data path parity), FSM(finite state > machine) fault and print the fault information in the kernel > log. I guess the subject and the patch log are a bit misleading. Safety IRQs have been supported by the kernel since commit 8bf993a5877e ("net: stmmac: Add support for DWMAC5 and implement Safety Features"). Meanwhile based on the patch body what you are doing here is adding the common safety IRQ line support. Please fix it. > > Signed-off-by: Suraj Jaiswal <quic_jsuraj@xxxxxxxxxxx> > --- > drivers/net/ethernet/stmicro/stmmac/common.h | 1 + > drivers/net/ethernet/stmicro/stmmac/stmmac.h | 2 ++ > .../net/ethernet/stmicro/stmmac/stmmac_main.c | 18 ++++++++++++++++++ > .../ethernet/stmicro/stmmac/stmmac_platform.c | 9 +++++++++ > 4 files changed, 30 insertions(+) > > diff --git a/drivers/net/ethernet/stmicro/stmmac/common.h b/drivers/net/ethernet/stmicro/stmmac/common.h > index 721c1f8e892f..cb9645fe16d8 100644 > --- a/drivers/net/ethernet/stmicro/stmmac/common.h > +++ b/drivers/net/ethernet/stmicro/stmmac/common.h > @@ -347,6 +347,7 @@ enum request_irq_err { > REQ_IRQ_ERR_SFTY_UE, > REQ_IRQ_ERR_SFTY_CE, > REQ_IRQ_ERR_LPI, > + REQ_IRQ_ERR_SAFETY, 1. For the sake of unification please use the REQ_IRQ_ERR_SFTY id instead, since the individual UE and CE IRQs have already been defined that way. 2. For readability please group up the IRQs of the same type. Like this: + REQ_IRQ_ERR_SFTY, REQ_IRQ_ERR_SFTY_UE, REQ_IRQ_ERR_SFTY_CE, * Note it would be also better to have the common IRQ ID being defined * above the individual ones. > REQ_IRQ_ERR_WOL, > REQ_IRQ_ERR_MAC, > REQ_IRQ_ERR_NO, > diff --git a/drivers/net/ethernet/stmicro/stmmac/stmmac.h b/drivers/net/ethernet/stmicro/stmmac/stmmac.h > index 9f89acf31050..aa2eda6fb927 100644 > --- a/drivers/net/ethernet/stmicro/stmmac/stmmac.h > +++ b/drivers/net/ethernet/stmicro/stmmac/stmmac.h > @@ -33,6 +33,7 @@ struct stmmac_resources { > int irq; > int sfty_ce_irq; > int sfty_ue_irq; > + int safety_common_irq; ditto: + int sfty_irq; int sfty_ce_irq; int sfty_ue_irq; Note there is no need in the "common" word in the name, just sfty_irq is enough to infer that it's a common IRQ number. > int rx_irq[MTL_MAX_RX_QUEUES]; > int tx_irq[MTL_MAX_TX_QUEUES]; > }; > @@ -299,6 +300,7 @@ struct stmmac_priv { > unsigned long active_vlans[BITS_TO_LONGS(VLAN_N_VID)]; > int sfty_ce_irq; > int sfty_ue_irq; > + int safety_common_irq; ditto: + int sfty_irq; int sfty_ce_irq; int sfty_ue_irq; > int rx_irq[MTL_MAX_RX_QUEUES]; > int tx_irq[MTL_MAX_TX_QUEUES]; > /*irq name */ > diff --git a/drivers/net/ethernet/stmicro/stmmac/stmmac_main.c b/drivers/net/ethernet/stmicro/stmmac/stmmac_main.c > index 47de466e432c..e4a0d9ec8b3f 100644 > --- a/drivers/net/ethernet/stmicro/stmmac/stmmac_main.c > +++ b/drivers/net/ethernet/stmicro/stmmac/stmmac_main.c > @@ -3592,6 +3592,10 @@ static void stmmac_free_irq(struct net_device *dev, > if (priv->wol_irq > 0 && priv->wol_irq != dev->irq) > free_irq(priv->wol_irq, dev); > fallthrough; > + case REQ_IRQ_ERR_SAFETY: > + if (priv->safety_common_irq > 0 && priv->safety_common_irq != dev->irq) > + free_irq(priv->safety_common_irq, dev); s/SAFETY/SFTY s/common_// s/safety/sfty > + fallthrough; > case REQ_IRQ_ERR_WOL: > free_irq(dev->irq, dev); > fallthrough; > @@ -3798,6 +3802,18 @@ static int stmmac_request_irq_single(struct net_device *dev) > } > } > > + if (priv->safety_common_irq > 0 && priv->safety_common_irq != dev->irq) { s/common_// s/safety/sfty > + ret = request_irq(priv->safety_common_irq, stmmac_safety_interrupt, s/safety_common_irq/sfty_irq > + 0, "safety", dev); The rest of the IRQ names are determined as: int_name = priv->int_name_sfty; sprintf(int_name, "%s:%s", dev->name, "safety"); ret = request_irq(priv->sfty_irq, stmmac_safety_interrupt, 0, int_name, dev); For maintainability it would be better to keep the code unified and have the same pattern implemented here too. > + if (unlikely(ret < 0)) { > + netdev_err(priv->dev, > + "%s: alloc safety failed %d (error: %d)\n", > + __func__, priv->safety_common_irq, ret); > + irq_err = REQ_IRQ_ERR_SAFETY; s/common_// s/safety/sfty s/SAFETY/SFTY > + goto irq_error; > + } > + } > + > return 0; > > irq_error: > @@ -7464,6 +7480,8 @@ int stmmac_dvr_probe(struct device *device, > priv->lpi_irq = res->lpi_irq; > priv->sfty_ce_irq = res->sfty_ce_irq; > priv->sfty_ue_irq = res->sfty_ue_irq; > + priv->safety_common_irq = res->safety_common_irq; > + s/common_// s/safety/sfty > for (i = 0; i < MTL_MAX_RX_QUEUES; i++) > priv->rx_irq[i] = res->rx_irq[i]; > for (i = 0; i < MTL_MAX_TX_QUEUES; i++) > diff --git a/drivers/net/ethernet/stmicro/stmmac/stmmac_platform.c b/drivers/net/ethernet/stmicro/stmmac/stmmac_platform.c > index 1ffde555da47..41a4a253d75b 100644 > --- a/drivers/net/ethernet/stmicro/stmmac/stmmac_platform.c > +++ b/drivers/net/ethernet/stmicro/stmmac/stmmac_platform.c > @@ -726,6 +726,15 @@ int stmmac_get_platform_resources(struct platform_device *pdev, > dev_info(&pdev->dev, "IRQ eth_lpi not found\n"); > } > > + stmmac_res->safety_common_irq = > + platform_get_irq_byname_optional(pdev, "safety"); Please define the IRQ resource name as "sfty" to be looking as the individual safety IRQ names. > + > + if (stmmac_res->safety_common_irq < 0) { > + if (stmmac_res->safety_common_irq == -EPROBE_DEFER) s/common_// s/safety/sfty -Serge(y) > + return -EPROBE_DEFER; > + dev_info(&pdev->dev, "IRQ safety IRQ not found\n"); > + } > + > stmmac_res->addr = devm_platform_ioremap_resource(pdev, 0); > > return PTR_ERR_OR_ZERO(stmmac_res->addr); > -- > 2.25.1 > >