On Wed, Nov 08, 2023 at 04:21:52PM +0800, Can Guo wrote: > Hi Mani, > > On 11/8/2023 1:23 PM, Manivannan Sadhasivam wrote: > > On Mon, Nov 06, 2023 at 08:46:09PM -0800, Can Guo wrote: > > > From: Can Guo <quic_cang@xxxxxxxxxxx> > > > > > > During host driver init, the phy_gear is set to the minimum supported gear > > > (HS_G2). Then, during the first power mode change, the negotiated gear, say > > > HS-G4, is updated to the phy_gear variable so that in the second init the > > > updated phy_gear can be used to program the PHY. > > > > > > But the current code only allows update the phy_gear to a higher value. If > > > one wants to start the first init with the maximum support gear, say HS-G4, > > > the phy_gear is not updated to HS-G3 if the device only supports HS-G3. > > > > > > > Can you elaborate when this can happen? AFAICS, there are 3 possibilities of > > initial phy gear with this series: > > > > 1. If ufshc is < 5.0, then G2 will be used. > > 2. If ufshc is >= 5.0 and if the version is populated in register, then that > > gear will be used. Most likely that gear can be G4/G5 depending on the device > > connected. > > 3. If ufshc is >=5.0 and version is not populated, then G4 will be used. > > > > In all the above cases, I do not see any necessity to switch the phy gear > > setting to lower one while scaling. Since the gears are backwards compatible, > > we always use one phy gear sequence. Moreover, we only have 2 init sequences. > > > > Please correct me if I'm missing anything. > > > > - Mani > In the next patch, I am setting the initial PHY gear to max HS gear read > from UFS host cap register, so that we don't need to keep updating the > initial value for host->phy_gear for different HW versions in future. FYI, > for HW ver 5 and 6, it is HS-G5. In future, the max gear might become HS-G6 > or higher on newer HW verions. > > I the case #3, if HS-G5 is set to host->phy_gear, the first init uses HS-G5, > then after negotiation if the agreed gear is HS-G4, we need to update > host->phy_gear to HS-G4 (a lower value) such that we use a power saving PHY > gear settings during the 2nd init. > > If the commit message is making you confused, I can update it in next > version. Please let me if I made any mistakes here. > I see redundancy while setting the phy_gear and it is leading to confusion. In ufs_qcom_set_host_params(), first you are setting phy_gear based on ufs_qcom_get_hs_gear(), then changing it again with the version check for v5. I don't see a necessity for "host->phy_gear = host_params->hs_tx_gear", since in the later check, you are covering both version <5 and >=5. Btw, it would be better to move this logic to a separate function like ufs_qcom_get_phy_gear() to align with ufs_qcom_get_hs_gear(). - Mani > Thanks, > Can Guo. -- மணிவண்ணன் சதாசிவம்