On 16.08.2023 16:57, Abel Vesa wrote: > Now that domains support being managed by the HW, lets add that > information to the genpd summary. > > Suggested-by: Taniya Das <quic_tdas@xxxxxxxxxxx> > Signed-off-by: Abel Vesa <abel.vesa@xxxxxxxxxx> > --- > drivers/base/power/domain.c | 15 +++++++++++++-- > 1 file changed, 13 insertions(+), 2 deletions(-) > > diff --git a/drivers/base/power/domain.c b/drivers/base/power/domain.c > index dfb4f1de540d..053b7b510825 100644 > --- a/drivers/base/power/domain.c > +++ b/drivers/base/power/domain.c > @@ -3171,6 +3171,15 @@ static void rtpm_status_str(struct seq_file *s, struct device *dev) > seq_printf(s, "%-25s ", p); > } > > +static void mode_status_str(struct seq_file *s, struct device *dev) > +{ > + struct generic_pm_domain_data *gpd_data; > + > + gpd_data = to_gpd_data(dev->power.subsys_data->domain_data); > + > + seq_printf(s, "%20s", gpd_data->hw_mode ? "HW_Mode" : "SW_Mode"); That's a very personal opinion and take it for what it is, but I think "_Mode" is excessive given the column is named "mode" Konrad