On Mon, Jul 10, 2023 at 06:16:22PM +0100, Mark Brown wrote: > On Mon, Jul 10, 2023 at 06:49:22PM +0300, Andy Shevchenko wrote: > > Seems by unknown reason, probably some kind of mis-rebase, > > the commit 0c79378c0199 ("spi: add ancillary device support") > > adds a dozen of duplicating lines of code. Drop them. > > > > Signed-off-by: Andy Shevchenko <andriy.shevchenko@xxxxxxxxxxxxxxx> > > --- > > drivers/spi/spi.c | 11 ----------- > > 1 file changed, 11 deletions(-) > > > > diff --git a/drivers/spi/spi.c b/drivers/spi/spi.c > > index c99ee4164f11..46cbda383228 100644 > > --- a/drivers/spi/spi.c > > +++ b/drivers/spi/spi.c > > @@ -712,17 +712,6 @@ EXPORT_SYMBOL_GPL(spi_add_device); > > static int spi_add_device_locked(struct spi_device *spi) > > { > > struct spi_controller *ctlr = spi->controller; > > - struct device *dev = ctlr->dev.parent; > > - > > - /* Chipselects are numbered 0..max; validate. */ > > - if (spi_get_chipselect(spi, 0) >= ctlr->num_chipselect) { > > - dev_err(dev, "cs%d >= max %d\n", spi_get_chipselect(spi, 0), > > - ctlr->num_chipselect); > > - return -EINVAL; > > - } > > - > > - /* Set the bus ID string */ > > - spi_dev_set_name(spi); > > I see that this is duplicating spi_add_device() (and we really could do > better with code sharing there I think) but I can't immediately see > where the duplication that's intended to be elimiated is here - where > else in the one call path that spi_add_device_locked() has would we do > the above? Based on the changelog I was expecting to see some > duplicated code in the function itself. Oh, by some reason Sebastian wasn't in this rather long Cc list. Added him. Reading again I don't see any useful explanation why that piece of code has to be duplicated among these two functions. It's 100% a copy. Sebastian, can you shed some light here? -- With Best Regards, Andy Shevchenko