On Thu, 16 Mar 2023 13:36:09 -0500 Andrew Halaney wrote: > static void emac3_config_cbs(struct mac_device_info *hw, u32 send_slope, > u32 idle_slope, u32 high_credit, > u32 low_credit, u32 queue) > > I agree, that's quite gnarly to read. the emac3_config_cbs is the > callback, so it's already at 6 arguments, so there's nothing I can > trim there. I could create some struct for readability, populate that, > then call the do_config_cbs() func with it from emac3_config_cbs. > Is that the sort of thing you want to see? Yes, a structure is much better, because it can be initialized member by member, struct bla my_bla = { .this = 1, .that = 2, .and = 3, another = 4, }; That's much easier to read. A poor man's version of Python's keyword arguments, if you will.