On Wed, 28 Sep 2022 17:57:46 +0530, Srinivasa Rao Mandadapu wrote: > Update ADSP pil loader driver for SC7280 platforms. > > Changes since V9: > -- Add missing unevaluatedProperties in dt-bindings glink-edge. > Changes since V8: > -- Add glink-edge reference in dt-bindings. > -- Remove redundant glinke-edge properties in dt-bindings. > -- Make all reg propertioes as mandatory in dt-bindings. > -- Add iommus property in dt-bindings. > Changes since V7: > -- Drop out of reset time out patch. > -- Remove redundant clocks in dt bindings. > -- Fix dt compilation error in dt bindings. > Changes since V6: > -- Update dt-bindings with glink-edge > -- Add qcom,qmp property. > -- Update parse firmware callback. > -- Update commit message. > -- Update smmu map and unmap function names. > -- Revert adsp_ops const change. > -- Move iommu check to within smmu map/unmap functions. > Changes since V5: > -- Remove adsp_rproc_unmap_smmu, adsp_of_unmap_smmu, adsp_of_map_smmu and > adsp_rproc_map_smmu functions. > -- Remove find_loaded_rsc_table call back initialization. > -- Rename adsp_sandbox_needed to has_iommu. > -- Update parse_fw callback in rproc ops. > -- Remove qcom,adsp-memory-regions property in dt-bindings. > -- Change adsp binary extension name. > Changes since V4: > -- Update halt registers description in dt bindings. > -- Update Memory sandboxing with proper APIs for resource > allocation and free. > Changes since V3: > -- Rename is_adsp_sb_needed to adsp_sandbox_needed. > -- Update sc7280 compatible name entry in sorted order. > -- Add smmu unmapping in error case and in adsp stop. > -- Revert converting sdm845 dt bindings to generic and > create new dt bindings for sc7280. > Changes since V2: > -- Generated patch with -M flag. > -- Add Clock property in dt bindings. > -- Add qcom,adsp-memory-regions property. > -- Add is_adsp_sb_needed flag instead of is_wpss. > -- Initialize is_adsp_sb_needed flag. > -- Remove empty proxy pds array. > -- Replace platform_bus_type with adsp->dev->bus. > -- Use API of_parse_phandle_with_args() instead of > of_parse_phandle_with_fixed_args(). > -- Replace adsp->is_wpss with adsp->is_adsp. > -- Update error handling in adsp_start(). > Changes since V1: > -- Change reg property maxItems to minItems and update description. > -- Fix typo errors. > > [...] Applied, thanks! [1/7] dt-bindings: remoteproc: qcom: Add SC7280 ADSP support commit: 8490a99586abd480d7139893f78c019790a58979 [2/7] remoteproc: qcom: Add flag in adsp private data structure commit: 272dca8d14c46d03c633756d150b1c48c1dcb594 [3/7] remoteproc: qcom: Add compatible name for SC7280 ADSP commit: 66cab0c5c3f9dae0213b9d02af03791b75565986 [4/7] remoteproc: qcom: Update rproc parse firmware callback commit: 48ab209c6f5f84a5adcd68e150dc0f614c8bfba7 [5/7] remoteproc: qcom: Replace hard coded values with macros commit: c36d6aa67932788ec04820ba65693ccd41b1042f [6/7] remoteproc: qcom: Add efuse evb selection control commit: 9ece961916631aab81b9d9f8d9c2770d05548662 [7/7] remoteproc: qcom: Add support for memory sandbox commit: f22eedff28aff912bde7f8deabebd121cb64fae3 Best regards, -- Bjorn Andersson <andersson@xxxxxxxxxx>