Re: [PATCH v6 7/8] remoteproc: qcom: Add support for memory sandbox

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 





On 9/8/22 6:53 PM, Srinivasa Rao Mandadapu wrote:
Update pil driver with SMMU mapping for allowing authorised
memory access to ADSP firmware, by carveout reserved adsp memory
region from device tree file.

Signed-off-by: Srinivasa Rao Mandadapu <quic_srivasam@xxxxxxxxxxx>
---
Changes since V5:
	-- Remove adsp_rproc_unmap_smmu, adsp_of_unmap_smmu, adsp_of_map_smmu and
	   adsp_rproc_map_smmu functions.
	-- Remove find_loaded_rsc_table call back initialization.
	-- Rename adsp_sandbox_needed to has_iommu.
Changes since V4:
	-- Split the code and add appropriate APIs for resource allocation and free.
	-- Update adsp_unmap_smmu with missing free ops call.
	-- Update normalizing length value in adsp_of_unmap_smmu.
Changes since V3:
	-- Rename is_adsp_sb_needed to adsp_sandbox_needed.
	-- Add smmu unmapping in error case and in adsp stop.
Changes since V2:
	-- Replace platform_bus_type with adsp->dev->bus.
	-- Use API of_parse_phandle_with_args() instead of of_parse_phandle_with_fixed_args().
	-- Replace adsp->is_wpss with adsp->is_adsp.
	-- Update error handling in adsp_start().

  drivers/remoteproc/qcom_q6v5_adsp.c | 55 ++++++++++++++++++++++++++++++++++++-
  1 file changed, 54 insertions(+), 1 deletion(-)

diff --git a/drivers/remoteproc/qcom_q6v5_adsp.c b/drivers/remoteproc/qcom_q6v5_adsp.c
index ccb5592..e55d593 100644
--- a/drivers/remoteproc/qcom_q6v5_adsp.c
+++ b/drivers/remoteproc/qcom_q6v5_adsp.c
@@ -9,6 +9,7 @@
  #include <linux/firmware.h>
  #include <linux/interrupt.h>
  #include <linux/io.h>
+#include <linux/iommu.h>
  #include <linux/iopoll.h>
  #include <linux/kernel.h>
  #include <linux/mfd/syscon.h>
@@ -48,6 +49,8 @@
  #define LPASS_PWR_ON_REG		0x10
  #define LPASS_HALTREQ_REG		0x0
+#define SID_MASK_DEFAULT 0xF
+
  #define QDSP6SS_XO_CBCR		0x38
  #define QDSP6SS_CORE_CBCR	0x20
  #define QDSP6SS_SLEEP_CBCR	0x3c
@@ -333,6 +336,42 @@ static int adsp_load(struct rproc *rproc, const struct firmware *fw)
  	return 0;
  }
+static void adsp_unmap_smmu(struct rproc *rproc)
+{
+	struct qcom_adsp *adsp = (struct qcom_adsp *)rproc->priv;
+
+	iommu_unmap(rproc->domain, adsp->mem_phys, adsp->mem_size);
+}
+
+static int adsp_map_smmu(struct qcom_adsp *adsp, struct rproc *rproc)

you could perhaps name the func to adsp_map_carveout/adsp_unmap_carveout


+{
+	struct of_phandle_args args;
+	long long sid;
+	unsigned long iova;
+	int ret;
+
+	if (!rproc->domain)
+		return -EINVAL;
+
+	ret = of_parse_phandle_with_args(adsp->dev->of_node, "iommus", "#iommu-cells", 0, &args);
+	if (ret < 0)
+		return ret;
+
+	sid = args.args[0] & SID_MASK_DEFAULT;
+
+	/* Add SID configuration for ADSP Firmware to SMMU */
+	iova =  adsp->mem_phys | (sid << 32);
+
+	ret = iommu_map(rproc->domain, iova, adsp->mem_phys,
+			adsp->mem_size,	IOMMU_READ | IOMMU_WRITE);
+	if (ret) {
+		dev_err(adsp->dev, "Unable to map ADSP Physical Memory\n");
+		return ret;
+	}
+
+	return 0;
+}
+
  static int adsp_start(struct rproc *rproc)
  {
  	struct qcom_adsp *adsp = (struct qcom_adsp *)rproc->priv;
@@ -343,9 +382,17 @@ static int adsp_start(struct rproc *rproc)
  	if (ret)
  		return ret;
+ if (adsp->has_iommu) {
+		ret = adsp_map_smmu(adsp, rproc);
+		if (ret) {
+			dev_err(adsp->dev, "ADSP smmu mapping failed\n");
+			goto disable_irqs;
+		}
+	}
+
  	ret = clk_prepare_enable(adsp->xo);
  	if (ret)
-		goto disable_irqs;
+		goto adsp_smmu_unmap;
ret = qcom_rproc_pds_enable(adsp, adsp->proxy_pds,
  				    adsp->proxy_pd_count);
@@ -401,6 +448,9 @@ static int adsp_start(struct rproc *rproc)
  	qcom_rproc_pds_disable(adsp, adsp->proxy_pds, adsp->proxy_pd_count);
  disable_xo_clk:
  	clk_disable_unprepare(adsp->xo);
+adsp_smmu_unmap:
+	if (adsp->has_iommu)
+		adsp_unmap_smmu(rproc);
  disable_irqs:
  	qcom_q6v5_unprepare(&adsp->q6v5);
@@ -429,6 +479,9 @@ static int adsp_stop(struct rproc *rproc)
  	if (ret)
  		dev_err(adsp->dev, "failed to shutdown: %d\n", ret);
+ if (adsp->has_iommu)
+		adsp_unmap_smmu(rproc);
+
  	handover = qcom_q6v5_unprepare(&adsp->q6v5);
  	if (handover)
  		qcom_adsp_pil_handover(&adsp->q6v5);




[Index of Archives]     [Linux ARM Kernel]     [Linux ARM]     [Linux Omap]     [Fedora ARM]     [Linux for Sparc]     [IETF Annouce]     [Security]     [Bugtraq]     [Linux MIPS]     [ECOS]     [Asterisk Internet PBX]     [Linux API]

  Powered by Linux