This series contains a set of cleanups done in preparation for a more substantitive upcoming series that reworks how IPA registers and their fields are defined. The first eliminates about half of the possible GSI register constant symbols by removing offset definitions that are not currently required. The next two mainly rearrange code for some common enumerated types. The next one fixes two spots that reuse local variable names in inner scopes when defining offsets. The next adds some additional restrictions on the value held in a register. And the last one just fixes two field mask symbol names so they adhere to the common naming convention. -Alex Alex Elder (6): net: ipa: don't define unneeded GSI register offsets net: ipa: move the definition of gsi_ee_id net: ipa: move and redefine ipa_version_valid() net: ipa: don't reuse variable names net: ipa: update sequencer definition constraints net: ipa: fix two symbol names drivers/net/ipa/gsi.h | 8 -- drivers/net/ipa/gsi_reg.h | 208 +++++++++------------------------ drivers/net/ipa/ipa_endpoint.c | 44 ++++--- drivers/net/ipa/ipa_main.c | 25 +--- drivers/net/ipa/ipa_reg.h | 5 +- drivers/net/ipa/ipa_version.h | 28 ++++- 6 files changed, 110 insertions(+), 208 deletions(-) -- 2.34.1