On Tue, 26 Jul 2022 at 17:24, Abel Vesa <abel.vesa@xxxxxxxxxx> wrote: > > Switch from the expanded rcg2 clocks definitions to the more compact > macros. > > Signed-off-by: Abel Vesa <abel.vesa@xxxxxxxxxx> > --- > drivers/clk/qcom/gcc-sdm845.c | 712 +++------------------------------- > 1 file changed, 51 insertions(+), 661 deletions(-) > > diff --git a/drivers/clk/qcom/gcc-sdm845.c b/drivers/clk/qcom/gcc-sdm845.c > index 2e66256599d3..d9751d7e617c 100644 > --- a/drivers/clk/qcom/gcc-sdm845.c > +++ b/drivers/clk/qcom/gcc-sdm845.c [skipped] > +DEFINE_QCOM_CC_CLK(RCG2, gcc_cpuss_ahb_clk_src, 0x48014, 0, 5, gcc_parent_map_0, ftbl_gcc_cpuss_ahb_clk_src, gcc_parent_data_7_ao); > +DEFINE_QCOM_CC_CLK(RCG2, gcc_cpuss_rbcpr_clk_src, 0x4815c, 0, 5, gcc_parent_map_3, ftbl_gcc_cpuss_rbcpr_clk_src, gcc_parent_data_8_ao); Well.. Stephen & Bjorn might have other opinions here. But for me there are just too many pieces of information on a single line. And different values start to meld into each other. So, e.g. I find it harder to comprehend what is going on here. What do 0 and 5 mean, etc. So while it takes less space, it looks harder to read. Compare this with the interconnect drivers, where a few releases ago we made an opposite switch: from using QNODE macros to the expanded structures. [skipped] > > DEFINE_QCOM_CC_CLK(BRANCH, HALT, gcc_aggre_noc_pcie_tbu_clk, 0, 0x90014, 0, 0, 0x90014, BIT(0), 0); And this is the perfect example. a series of 0, 1 and BIT(0). What do they mean? And where is the parent, which is defined for the next clocks? > DEFINE_QCOM_CC_CLK(BRANCH, HALT, gcc_aggre_ufs_card_axi_clk, 1, 0x82028, 0x82028, 1, 0x82028, BIT(0), CLK_SET_RATE_PARENT, &gcc_ufs_card_axi_clk_src.clkr.hw); -- With best wishes Dmitry