On 2/21/2022 10:22 PM, Dmitry Baryshkov wrote:
Recent dicussion on the mailing list [1], [2] outlined a need to document which intf type is used for DP and which one is used for eDP interfaces. This series implements my proposal [3]: - Keep INTF_EDP reserved for 8x74/8x84 - Use INTF_DP for all contemporary DP and eDP ports - Documet this in dpu_hw_mdss.h - Remove INTF_EDP usage in dpu1 driver. Main reasons behind this proposal: - It's not always possible to separate eDP and DP. For example INTF_5 on sc7280 is connected to combo eDP/DP PHY. - Using INTF_EDP would require us to split too many pieces, ending up with a singnificant amount of code duplication... - ... for nothing. From the DPU point of view there is no difference between DP and eDP interfaces as found on current SoC generations. [1]: https://lore.kernel.org/linux-arm-msm/0dac8ffa-89a6-d972-bdc1-3f7755c5169d@xxxxxxxxxx/ [2]: https://lore.kernel.org/linux-arm-msm/be397e2e-05ab-5c18-8e2d-16c443f0a6d1@xxxxxxxxxxx/ [3]: https://lore.kernel.org/linux-arm-msm/e2fab93e-82a6-4837-4ee5-ee1b16caa84d@xxxxxxxxxx/
I have notified the team about the change and we have discussed the potential implications of this with both upstream and downstream drivers in mind. Overall, even though some members wanted to retain INTF_eDP for clarity, some members were fine removing its usage.
Going with the majority and I have checked all the changes in this series, Hence: Reviewed-by: Abhinav Kumar <quic_abhinavk@xxxxxxxxxxx> For the entire series.
Dmitry Baryshkov (4): drm/msm/dpu: document INTF_EDP/INTF_DP difference drm/msm/dpu: drop INTF_TYPE_MAX symbol drm/msm/dpu: drop obsolete INTF_EDP comment drm/msm/dpu: drop INTF_EDP from interface type conditions .../gpu/drm/msm/disp/dpu1/dpu_encoder_phys_vid.c | 14 +------------- drivers/gpu/drm/msm/disp/dpu1/dpu_hw_intf.c | 2 +- drivers/gpu/drm/msm/disp/dpu1/dpu_hw_mdss.h | 9 ++++++++- 3 files changed, 10 insertions(+), 15 deletions(-)