Re: [PATCH 2/2] serial: msm: Add support for UARTDM cores

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Wed, Jan 19, 2011 at 09:31:55AM -0800, David Brown wrote:
> On Wed, Jan 19 2011, Jamie Iles wrote:
> 
> >> @@ -38,9 +40,20 @@ struct msm_port {
> >>  	struct uart_port	uart;
> >>  	char			name[16];
> >>  	struct clk		*clk;
> >> +	struct clk		*pclk;
> >>  	unsigned int		imr;
> >> +	unsigned int            *gsbi_base;
> >> +	int			is_dm;
> >> +	unsigned int		old_snap_state;
> >>  };
> >
> > Out of interest, what does .is_dm mean?  Is that obvious to someone who 
> > knows about msm?
> 
> It would be clear to people rather familiar with the chip, but I agree
> it's probably not that clear of a name.
> 
> We have two UART blocks we use in the MSMs, the older one, supported by
> this driver before this change, and a newer one that was designed to
> work with our DMA engine (known as the Data Mover, or dm).  This newer
> UART can be used in a somewhat compatible manner when being used for
> serial-port type operations.
> 
> I'm not sure what would be a better name for the flag, though.  The
> block is called UARTDM.

Ok, it was mainly out of curiosity.  I guess it could be 'use_dma' or 
perhaps a comment to explain what DM is but my curiosity is now 
satisfied ;-)

Jamie
--
To unsubscribe from this list: send the line "unsubscribe linux-arm-msm" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html


[Index of Archives]     [Linux ARM Kernel]     [Linux ARM]     [Linux Omap]     [Fedora ARM]     [Linux for Sparc]     [IETF Annouce]     [Security]     [Bugtraq]     [Linux MIPS]     [ECOS]     [Asterisk Internet PBX]     [Linux API]

  Powered by Linux