Re: [PATCH v1 1/1] x86: Rename __{start,end}_init_task to __{start,end}_init_stack

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On 3/13/2024 12:09 AM, Jürgen Groß wrote:
On 13.03.24 07:05, Xin Li (Intel) wrote:
The stack of a task has been separated from the memory of a task_struct
struture for a long time on x86, as a result __{start,end}_init_task no
longer mark the start and end of the init_task structure, but its stack
only.

Rename __{start,end}_init_task to __{start,end}_init_stack.

Note other architectures are not affected because __{start,end}_init_task
are used on x86 only.


diff --git a/include/asm-generic/vmlinux.lds.h b/include/asm-generic/vmlinux.lds.h
index 5dd3a61d673d..a168be99d522 100644
--- a/include/asm-generic/vmlinux.lds.h
+++ b/include/asm-generic/vmlinux.lds.h
@@ -399,13 +399,13 @@
  #define INIT_TASK_DATA(align)                        \
      . = ALIGN(align);                        \
-    __start_init_task = .;                        \
+    __start_init_stack = .;                        \
      init_thread_union = .;                        \
      init_stack = .;                            \
-    KEEP(*(.data..init_task))                    \
+    KEEP(*(.data..init_stack))                    \

Is this modification really correct?


Good catch, I should not change it.

Thanks!
    Xin





[Index of Archives]     [Linux Kernel]     [Kernel Newbies]     [x86 Platform Driver]     [Netdev]     [Linux Wireless]     [Netfilter]     [Bugtraq]     [Linux Filesystems]     [Yosemite Discussion]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Samba]     [Device Mapper]

  Powered by Linux