On Thu, Feb 15, 2024 at 08:22:29PM +0100, Rafael J. Wysocki wrote: > On Wed, Jan 31, 2024 at 5:50 PM Russell King <rmk+kernel@xxxxxxxxxxxxxxx> wrote: > > diff --git a/drivers/acpi/acpi_processor.c b/drivers/acpi/acpi_processor.c > > index cf7c1cca69dd..a68c475cdea5 100644 > > --- a/drivers/acpi/acpi_processor.c > > +++ b/drivers/acpi/acpi_processor.c > > @@ -314,6 +314,18 @@ static int acpi_processor_get_info(struct acpi_device *device) > > cpufreq_add_device("acpi-cpufreq"); > > } > > > > + /* > > + * Register CPUs that are present. get_cpu_device() is used to skip > > + * duplicate CPU descriptions from firmware. > > + */ > > + if (!invalid_logical_cpuid(pr->id) && cpu_present(pr->id) && > > + !get_cpu_device(pr->id)) { > > + int ret = arch_register_cpu(pr->id); > > + > > + if (ret) > > + return ret; > > + } > > + > > /* > > * Extra Processor objects may be enumerated on MP systems with > > * less than the max # of CPUs. They should be ignored _iff > > This is interesting, because right below there is the following code: > > if (invalid_logical_cpuid(pr->id) || !cpu_present(pr->id)) { > int ret = acpi_processor_hotadd_init(pr); > > if (ret) > return ret; > } > > and acpi_processor_hotadd_init() essentially calls arch_register_cpu() > with some extra things around it (more about that below). > > I do realize that acpi_processor_hotadd_init() is defined under > CONFIG_ACPI_HOTPLUG_CPU, so for the sake of the argument let's > consider an architecture where CONFIG_ACPI_HOTPLUG_CPU is set. > > So why are the two conditionals that almost contradict each other both > needed? It looks like the new code could be combined with > acpi_processor_hotadd_init() to do the right thing in all cases. > > Now, acpi_processor_hotadd_init() does some extra things that look > like they should be done by the new code too. > > 1. It checks invalid_phys_cpuid() which appears to be a good idea to me. > > 2. It uses locking around arch_register_cpu() which doesn't seem > unreasonable either. > > 3. It calls acpi_map_cpu() and I'm not sure why this is not done by > the new code. > > The only thing that can be dropped from it is the _STA check AFAICS, > because acpi_processor_add() won't even be called if the CPU is not > present (and not enabled after the first patch). > > So why does the code not do 1 - 3 above? Honestly, I'm out of my depth with this and can't answer your questions - and I really don't want to try fiddling with this code because it's just too icky (even in its current form in mainline) to be understandable to anyone who hasn't gained a detailed knowledge of this code. It's going to require a lot of analysis - how acpi_map_cpuid() behaves in all circumstances, what this means for invalid_logical_cpuid() and invalid_phys_cpuid(), what paths will be taken in each case. This code is already just too hairy for someone who isn't an experienced ACPI hacker to be able to follow and I don't see an obvious way to make it more readable. James' additions make it even more complex and less readable. -- RMK's Patch system: https://www.armlinux.org.uk/developer/patches/ FTTP is here! 80Mbps down 10Mbps up. Decent connectivity at last!