Re: [PATCH v2 09/10] mm/mmu_gather: improve cond_resched() handling with large folios and expensive page freeing

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On 12.02.24 11:32, Ryan Roberts wrote:
On 12/02/2024 10:11, David Hildenbrand wrote:
Hi Ryan,

-static void tlb_batch_pages_flush(struct mmu_gather *tlb)
+static void __tlb_batch_free_encoded_pages(struct mmu_gather_batch *batch)
   {
-    struct mmu_gather_batch *batch;
-
-    for (batch = &tlb->local; batch && batch->nr; batch = batch->next) {
-        struct encoded_page **pages = batch->encoded_pages;
+    struct encoded_page **pages = batch->encoded_pages;
+    unsigned int nr, nr_pages;
   +    /*
+     * We might end up freeing a lot of pages. Reschedule on a regular
+     * basis to avoid soft lockups in configurations without full
+     * preemption enabled. The magic number of 512 folios seems to work.
+     */
+    if (!page_poisoning_enabled_static() && !want_init_on_free()) {

Is the performance win really worth 2 separate implementations keyed off this?
It seems a bit fragile, in case any other operations get added to free which are
proportional to size in future. Why not just always do the conservative version?

I really don't want to iterate over all entries on the "sane" common case. We
already do that two times:

a) free_pages_and_swap_cache()

b) release_pages()

Only the latter really is required, and I'm planning on removing the one in (a)
to move it into (b) as well.

So I keep it separate to keep any unnecessary overhead to the setups that are
already terribly slow.

No need to iterate a page full of entries if it can be easily avoided.
Especially, no need to degrade the common order-0 case.

Yeah, I understand all that. But given this is all coming from an array, (so
easy to prefetch?) and will presumably all fit in the cache for the common case,
at least, so its hot for (a) and (b), does separating this out really make a
measurable performance difference? If yes then absolutely this optimizaiton
makes sense. But if not, I think its a bit questionable.

I primarily added it because

(a) we learned that each cycle counts during mmap() just like it does during fork().

(b) Linus was similarly concerned about optimizing out another batching walk in c47454823bd4 ("mm: mmu_gather: allow more than one batch of delayed rmaps"):

"it needs to walk that array of pages while still holding the page table lock, and our mmu_gather infrastructure allows for batching quite a lot of pages. We may have thousands on pages queued up for freeing, and we wanted to walk only the last batch if we then added a dirty page to the queue."

So if it matters enough for reducing the time we hold the page table lock, it surely adds "some" overhead in general.



You're the boss though, so if your experience tells you this is neccessary, then
I'm ok with that.

I did not do any measurements myself, I just did that intuitively as above. After all, it's all pretty straight forward (keeping the existing logic, we need a new one either way) and not that much code.

So unless there are strong opinions, I'd just leave the common case as it was, and the odd case be special.


By the way, Matthew had an RFC a while back that was doing some clever things
with batches further down the call chain (I think; be memory). Might be worth
taking a look at that if you are planning a follow up change to (a).


Do you have a pointer?



           while (batch->nr) {
-            /*
-             * limit free batch count when PAGE_SIZE > 4K
-             */
-            unsigned int nr = min(512U, batch->nr);
+            nr = min(512, batch->nr);

If any entries are for more than 1 page, nr_pages will also be encoded in the
batch, so effectively this could be limiting to 256 actual folios (half of 512).

Right, in the patch description I state "256 folio fragments". It's up to 512
folios (order-0).

Is it worth checking for ENCODED_PAGE_BIT_NR_PAGES_NEXT and limiting accordingly?

At least with 4k page size, we never have more than 510 (IIRC) entries per batch
page. So any such optimization would only matter for large page sizes, which I
don't think is worth it.

Yep; agreed.


Which exact optimization do you have in mind and would it really make a difference?

No I don't think it would make any difference, performance-wise. I'm just
pointing out that in pathalogical cases you could end up with half the number of
pages being freed at a time.

Yes, I'll extend the patch description!




nit: You're using 512 magic number in 2 places now; perhaps make a macro?

I played 3 times with macro names (including just using something "intuitive"
like MAX_ORDER_NR_PAGES) but returned to just using 512.

That cond_resched() handling is just absolutely disgusting, one way or the other.

Do you have a good idea for a macro name?

MAX_NR_FOLIOS_PER_BATCH?
MAX_NR_FOLIOS_PER_FREE?

I don't think the name has to be perfect, because its private to the c file; but
it ensures the 2 usages remain in sync if someone wants to change it in future.

Makes sense, I'll use something along those lines.




                 /*
                * Make sure we cover page + nr_pages, and don't leave
@@ -119,6 +120,37 @@ static void tlb_batch_pages_flush(struct mmu_gather *tlb)
               cond_resched();
           }
       }
+
+    /*
+     * With page poisoning and init_on_free, the time it takes to free
+     * memory grows proportionally with the actual memory size. Therefore,
+     * limit based on the actual memory size and not the number of involved
+     * folios.
+     */
+    while (batch->nr) {
+        for (nr = 0, nr_pages = 0;
+             nr < batch->nr && nr_pages < 512; nr++) {
+            if (unlikely(encoded_page_flags(pages[nr]) &
+                     ENCODED_PAGE_BIT_NR_PAGES_NEXT))
+                nr_pages += encoded_nr_pages(pages[++nr]);
+            else
+                nr_pages++;
+        }

I guess worst case here is freeing (511 + 8192) * 64K pages = ~544M. That's up
from the old limit of 512 * 64K = 32M, and 511 pages bigger than your statement
in the commit log. Are you comfortable with this? I guess the only alternative
is to start splitting a batch which would be really messy. I agree your approach
is preferable if 544M is acceptable.

Right, I have in the description:

"if we cannot even free a single MAX_ORDER page on a system without running into
soft lockups, something else is already completely bogus.".

That would be 8192 pages on arm64. Anybody freeing a PMD-mapped THP would be in
trouble already and should just reconsider life choices running such a machine.

We could have 511 more pages, yes. If 8192 don't trigger a soft-lockup, I am
confident that 511 more pages won't make a difference.

But, if that ever is a problem, we can butcher this code as much as we want,
because performance with poisoning/zeroing is already down the drain.

As you say, splitting even further is messy, so I rather avoid that unless
really required.


Yep ok, I understand the argument better now - thanks.


I'll further extend the patch description.

Thanks!

--
Cheers,

David / dhildenb





[Index of Archives]     [Linux Kernel]     [Kernel Newbies]     [x86 Platform Driver]     [Netdev]     [Linux Wireless]     [Netfilter]     [Bugtraq]     [Linux Filesystems]     [Yosemite Discussion]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Samba]     [Device Mapper]

  Powered by Linux