On Tue, Feb 01, 2022 at 11:05:39PM +0800, guoren@xxxxxxxxxx wrote: > +bool compat_elf_check_arch(Elf32_Ehdr *hdr) > +{ > + if (compat_mode_support && (hdr->e_machine == EM_RISCV)) > + return true; > + else > + return false; > +} This can be simplified to: return compat_mode_support && hdr->e_machine == EM_RISCV; I'd also rename compat_mode_support to compat_mode_supported > + > +static int compat_mode_detect(void) > +{ > + unsigned long tmp = csr_read(CSR_STATUS); > + > + csr_write(CSR_STATUS, (tmp & ~SR_UXL) | SR_UXL_32); > + > + if ((csr_read(CSR_STATUS) & SR_UXL) != SR_UXL_32) { > + pr_info("riscv: 32bit compat mode detect failed\n"); > + compat_mode_support = false; > + } else { > + compat_mode_support = true; > + pr_info("riscv: 32bit compat mode detected\n"); > + } I don't think we need these printks here. Also this could be simplified to: compat_mode_supported = (csr_read(CSR_STATUS) & SR_UXL) == SR_UXL_32;