On Sat, Dec 18, 2021 at 09:52:04PM +0300, Nikita Yushchenko wrote: > For architectures that use free_page_and_swap_cache() as their > __tlb_remove_table(), place that common implementation into > mm/mmu_gather.c, ifdef'ed by CONFIG_MMU_GATHER_TABLE_FREE_COMMON. > > Signed-off-by: Nikita Yushchenko <nikita.yushchenko@xxxxxxxxxxxxx> > --- > arch/Kconfig | 3 +++ > arch/arm/Kconfig | 1 + > arch/arm/include/asm/tlb.h | 5 ----- > arch/arm64/Kconfig | 1 + > arch/arm64/include/asm/tlb.h | 5 ----- > arch/x86/Kconfig | 1 + > arch/x86/include/asm/tlb.h | 14 -------------- > include/asm-generic/tlb.h | 5 +++++ > mm/mmu_gather.c | 10 ++++++++++ > 9 files changed, 21 insertions(+), 24 deletions(-) > > diff --git a/arch/Kconfig b/arch/Kconfig > index d3c4ab249e9c..9eba553cd86f 100644 > --- a/arch/Kconfig > +++ b/arch/Kconfig > @@ -415,6 +415,9 @@ config HAVE_ARCH_JUMP_LABEL_RELATIVE > config MMU_GATHER_TABLE_FREE > bool > > +config MMU_GATHER_TABLE_FREE_COMMON > + bool I don't like that name... The point isn't that it's common, the point is that the page-table's are backed by pages.