On Wed, Jun 16, 2021 at 1:00 PM Linus Torvalds <torvalds@xxxxxxxxxxxxxxxxxxxx> wrote: > > And even for debugging, I think it would be both easier and cheaper to > just add a magic word to the entry stack instead. IOW, just add a unsigned long magic; to "struct switch_stack", and then make the stack switch code push that value. That would be cheap enough to be just unconditional, but you could make it depend on a debug config option too, of course. It helps if 'xyz' is some constant that is easyish to generate. It might not be a constant - maybe it could be the address of that 'magic' field itself, so you'd just generate it with stq $r,($r) and it would be equally easy to just validate at lookup for that WARN_ON_ONCE(): WARN_ON_ONCE(switch_stack->magic != (unsigned long)&switch_stack->magic); or whatever. It's for debugging, not security. So it doesn't have to be some kind of super-great magic number, just something easy to generate and check (that isn't a common value like "0" that trivially exist on the stack anyway). Linus