Hi Mike, On Fri, Jun 4, 2021 at 8:50 AM Mike Rapoport <rppt@xxxxxxxxxx> wrote: > From: Mike Rapoport <rppt@xxxxxxxxxxxxx> > > After removal of DISCINTIGMEM the NEED_MULTIPLE_NODES and NUMA > configuration options are equivalent. > > Drop CONFIG_NEED_MULTIPLE_NODES and use CONFIG_NUMA instead. > > Done with > > $ sed -i 's/CONFIG_NEED_MULTIPLE_NODES/CONFIG_NUMA/' \ > $(git grep -wl CONFIG_NEED_MULTIPLE_NODES) > $ sed -i 's/NEED_MULTIPLE_NODES/NUMA/' \ > $(git grep -wl NEED_MULTIPLE_NODES) > > with manual tweaks afterwards. > > Signed-off-by: Mike Rapoport <rppt@xxxxxxxxxxxxx> Thanks for your patch! As you dropped the following hunk from v2 of PATCH 5/9, there's now one reference left of CONFIG_NEED_MULTIPLE_NODES (plus the discontigmem comment): -diff --git a/mm/memory.c b/mm/memory.c -index f3ffab9b9e39157b..fd0ebb63be3304f5 100644 ---- a/mm/memory.c -+++ b/mm/memory.c -@@ -90,8 +90,7 @@ - #warning Unfortunate NUMA and NUMA Balancing config, growing page-frame for last_cpupid. - #endif - --#ifndef CONFIG_NEED_MULTIPLE_NODES --/* use the per-pgdat data instead for discontigmem - mbligh */ -+#ifdef CONFIG_FLATMEM - unsigned long max_mapnr; - EXPORT_SYMBOL(max_mapnr); - Gr{oetje,eeting}s, Geert -- Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@xxxxxxxxxxxxxx In personal conversations with technical people, I call myself a hacker. But when I'm talking to journalists I just say "programmer" or something like that. -- Linus Torvalds