----- On Mar 6, 2020, at 12:55 PM, rostedt rostedt@xxxxxxxxxxx wrote: > On Fri, 6 Mar 2020 11:04:28 -0500 (EST) > Mathieu Desnoyers <mathieu.desnoyers@xxxxxxxxxxxx> wrote: > >> If we care about not adding those extra branches on the fast-path, there is >> an alternative way to do things: BPF could provide two distinct probe callbacks, >> one meant for rcuidle tracepoints (which would have the trace_rcu_enter/exit), >> and >> the other for the for 99% of the other callsites which have RCU watching. >> >> I would recommend performing benchmarks justifying the choice of one approach >> over >> the other though. > > I just whipped this up (haven't even tried to compile it), but this should > satisfy everyone. Those that register a callback that needs RCU protection > simply registers with one of the _rcu versions, and all will be done. And > since DO_TRACE is a macro, and rcuidle is a constant, the rcu protection > code will be compiled out for locations that it is not needed. > > With this, perf doesn't even need to do anything extra but register with > the "_rcu" version. > > -- Steve > [...] > diff --git a/kernel/tracepoint.c b/kernel/tracepoint.c > index 73956eaff8a9..1797e20fd471 100644 > --- a/kernel/tracepoint.c > +++ b/kernel/tracepoint.c > @@ -295,6 +295,7 @@ static int tracepoint_remove_func(struct tracepoint *tp, > * @probe: probe handler > * @data: tracepoint data > * @prio: priority of this function over other registered functions > + * @rcu: set to non zero if the callback requires RCU protection > * > * Returns 0 if ok, error value on error. > * Note: if @tp is within a module, the caller is responsible for > @@ -302,8 +303,8 @@ static int tracepoint_remove_func(struct tracepoint *tp, > * performed either with a tracepoint module going notifier, or from > * within module exit functions. > */ > -int tracepoint_probe_register_prio(struct tracepoint *tp, void *probe, > - void *data, int prio) > +int tracepoint_probe_register_prio_rcu(struct tracepoint *tp, void *probe, > + void *data, int prio, int rcu) I agree with the overall approach. Just a bit of nitpicking on the API: I understand that the "prio" argument is a separate argument because it can take many values. However, "rcu" is just a boolean, so I wonder if we should not rather introduce a "int flags" with a bitmask enum, e.g. int tracepoint_probe_register_prio_flags(struct tracepoint *tp, void *probe, void *data, int prio, int flags) where flags would be populated through OR between labels of this enum: enum tracepoint_flags { TRACEPOINT_FLAG_RCU = (1U << 0), }; We can then be future-proof for additional flags without ending up calling e.g. tracepoint_probe_register_featurea_featureb_featurec(tp, probe, data, 0, 1, 0, 1) which seems rather error-prone and less readable than a set of flags. Thanks, Mathieu -- Mathieu Desnoyers EfficiOS Inc. http://www.efficios.com