On Tue, 20 Aug 2019 at 04:50, Daniel Axtens <dja@xxxxxxxxxx> wrote: > > Currently bitops-instrumented.h assumes that the architecture provides > atomic, non-atomic and locking bitops (e.g. both set_bit and __set_bit). > This is true on x86 and s390, but is not always true: there is a > generic bitops/non-atomic.h header that provides generic non-atomic > operations, and also a generic bitops/lock.h for locking operations. > > powerpc uses the generic non-atomic version, so it does not have it's > own e.g. __set_bit that could be renamed arch___set_bit. > > Split up bitops-instrumented.h to mirror the atomic/non-atomic/lock > split. This allows arches to only include the headers where they > have arch-specific versions to rename. Update x86 and s390. > > (The generic operations are automatically instrumented because they're > written in C, not asm.) > > Suggested-by: Christophe Leroy <christophe.leroy@xxxxxx> > Reviewed-by: Christophe Leroy <christophe.leroy@xxxxxx> > Signed-off-by: Daniel Axtens <dja@xxxxxxxxxx> Acked-by: Marco Elver <elver@xxxxxxxxxx> Thanks!