* Linus Torvalds: >> A different approach would rename <asm/posix_types.h> to something more >> basic, exclude the two structs, and move all internal #includes which do >> need the structs to the new header. > > In fact, I wouldn't even rename <posix_types.h> at all, I'd just make > sure it's namespace-clean. > > I _think_ the only thing causing problems is '__kernel_fsid_t' due to > that "val[]" thing, so just remove ity entirely, and add it to > <statfs.h> instead. There's also __kernel_fd_set in <linux/posix_types.h>. I may have lumped this up with <asm/posix_types.h>, but it has the same problem. If it's okay to move them both to more natural places (maybe <asm/statfs.h> and <linux/socket.h>), I think that should work well for glibc. However, application code may have to include additional header files. I think the GCC/LLVM sanitizers currently get __kernel_fd_set from <linux/posix_types.h> (but I think we discussed it before, they really shouldn't use this type because it's misleading). Thanks, Florian