Hi Firoz, On Tue, Dec 11, 2018 at 02:15:19PM +0530, Firoz Khan wrote: > > > diff --git a/arch/mips/include/uapi/asm/sgidefs.h b/arch/mips/include/uapi/asm/sgidefs.h > > > index 26143e3..0364eec 100644 > > > --- a/arch/mips/include/uapi/asm/sgidefs.h > > > +++ b/arch/mips/include/uapi/asm/sgidefs.h > > > @@ -40,6 +40,6 @@ > > > */ > > > #define _MIPS_SIM_ABI32 1 > > > #define _MIPS_SIM_NABI32 2 > > > -#define _MIPS_SIM_ABI64 3 > > > +#define _MIPS_SIM_ABIN64 3 > > > > Whilst I agree with changing our own definitions & filenames to use n64, > > this macro actually reflects naming used by the toolchain. ie: > > > > $ mips-linux-gcc -mips64 -mabi=64 -dM -E - </dev/null | grep ABI64 > > #define _ABI64 3 > > #define _MIPS_SIM _ABI64 > > > > Our macro here is used to compare against _MIPS_SIM provided by the > > toolchain, so for consistency I think we should keep the same name for > > the macro that the toolchain uses. > > Will this below change will help? > > #define _MIPS_SIM_ABI32 1 > #define _MIPS_SIM_NABI32 2 > #define _MIPS_SIM_ABI64 3 > +#define _MIPS_SIM_ABIN64 _MIPS_SIM_ABI64 Hmm, I think I'd prefer that we just keep using _MIPS_SIM_ABI64. Side note - this snippet of code shows another inconsistency... we have _MIPS_SIM_NABI32 whilst the toolchain uses _ABIN32... No need to worry about that here though. In short let's leave _MIPS_SIM_* alone in this series. Thanks, Paul