On Tue, Jul 10, 2018 at 03:26:22PM -0700, Yu-cheng Yu wrote: > +static inline bool is_shstk_pte(pte_t pte) > +{ > + pteval_t val; > + > + val = pte_flags(pte) & (_PAGE_RW | _PAGE_DIRTY_HW); > + return (val == _PAGE_DIRTY_HW); > +} That's against naming convention here. static inline bool pte_shstk(pte_t pte) { return pte_flags(pte) & (_PAGE_RW | _PAGE_DIRTY_HW) == _PAGE_DIRTY_HW; } would be more in style with the rest of this code.