On Tue, May 8, 2018 at 4:26 PM, William Breathitt Gray <vilhelm.gray@xxxxxxxxx> wrote: > This macro iterates for each group of bits (port word) with set bits, > within a bitmap memory region. For each iteration, "port_word" is set to > the found port word index, "word_index" is set to the word index of the > bitmap containing the found port word, and "word_offset" is set to the > bit offset of the found port word within the respective bitmap word. Isn't that idea we discussed some time ago? In any case, part "port" is too specific for a generic function like this. Please, get rid of it completely. No-one knows what port means here. Just makes a lot of confusion. > --- a/lib/find_bit.c > +++ b/lib/find_bit.c > @@ -20,6 +20,7 @@ > #include <linux/bitmap.h> > #include <linux/export.h> > #include <linux/kernel.h> > +#include <linux/types.h> No need. It's included by bitmap.h IIRC. -- With Best Regards, Andy Shevchenko