* Dominik Brodowski <linux@xxxxxxxxxxxxxxxxxxxx> wrote: > On Sun, Apr 08, 2018 at 10:35:50AM +0200, Ingo Molnar wrote: > > - _____sys_waitid() # ridiculous number of underscores? > > - __sys_waitid() # too generic sounding? > > ... and we'd need to rename internal helpers in net/ > > > - __inline_sys_waitid() # too long? > > sounds acceptable, though a bit long (especially for the compat case, though > it doesn't really matter in the case of > __inline_compat_sys_sched_rr_get_interval) So as per the previous mail this is not just an inline function, but an active type conversion wrapper that sign-extends 32-bit ints to longs, which is important on some 64-bit architectures. And that's a really non-obvious property IMO, and the name should probably reflect _that_ non-obvious property, not the inlining property which is really just a small detail. I.e. how about: __se_sys_waitid() ... where 'se' stands for sign-extended, with a comment in the macro that explains the prefix? (The historical abbreviation for sign extension is 'sext', which I think wouldn't really be suitable these days.) Thanks, Ingo