On Thu, Feb 15, 2018 at 7:07 PM, John Garry <john.garry@xxxxxxxxxx> wrote: > On 14/02/2018 16:16, Andy Shevchenko wrote: >>>>> >>> + list_for_each_entry(rentry, &resource_list, node) >>>>> >>> + resources[count++] = *rentry->res; >>>> >>>> >> It has similarities with acpi_create_platform_device(). >>>> >> I guess we can utilize existing code. >>> >>> > For sure, this particular segment is effectively same as part of >>> > acpi_create_platform_device(): >> >> Not the same, acpi_create_platform_device() does a bit more than >> copying the resources. If it indeed makes no hurt... >> >>> > list_for_each_entry(rentry, &resource_list, node) >>> > acpi_platform_fill_resource(adev, rentry->res, >>> > &resources[count++]); >>> > So is your idea to refactor this common segment into a helper function? >> >> ...I would go with helper. >> > > Hi Andy, > > Since the plan now is that this code is no longer going to be added to > drivers/acpi, but instead pushed to the LLDD, I am pondering whether we > should still factor out of this common code. Opinion? I would still go with a common helper. Though, as first step, we can make it lazy, i.e. put a comment in your code, like a todo notice (w/o TODO word :-) ) to consider a common helper. -- With Best Regards, Andy Shevchenko