On Wed, Oct 25, 2017 at 05:28:41PM +0200, Clement Courbet wrote: > Thanks for the comments Yury. > > > But I'd like also to keep _find_next_bit() consistent with > > _find_next_bit_le() > > Not sure I understand what you're suggesting here: Do you want a > find_next_and_bit_le() or do you want to make _find_next_bit_le() more > like _find_next_bit() ? In the latter case we might just want to merge > it with _find_next_bit() and end up with an extra is_le parameter :) Both ways will work, but I think that extra is_le is too much. _find_next_bit_le() should be the copy of _find_next_bit() with the addition of swapping code. If you don't need find_next_and_bit_le(), don't add it. find_{first,last}_bit() doesn't have LE version, for example. Yury