On Wednesday 11 May 2016 10:04:16 Zhangjian wrote: > > I don't remember. It's probably not important whether we have the shift > > in there, as long as it's independent of the actual kernel page size and > > user space and kernel agree on the calling conventions. > Well. I am ok with where to shift the pages size because we get the same > result. I was just thinking if we should get rid of the name of mmap2 in our > ILP32 porting. Actually, it is mmap but we name it as mmap2. User may confused > if they do not know the implementations. That is a good point: If the implementation matches the mmap() behavior rather than mmap2(), we should rename the macro by doing #undef __NR_mmap2 #define __NR_mmap 222 in the uapi/asm/unistd.h file for ilp32 mode. Alternatively we can keep the __NR_mmap2 definition but then we need to pass the pgoff (value shifted by 12 bits) argument rather than the size in bytes. Arnd -- To unsubscribe from this list: send the line "unsubscribe linux-arch" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html