>> Minor style nit: is it necessary to name a non-pointer variable "p"? >> I expect typeof(p) to be a pointer type. > v might be better. The current ACCESS_ONCE uses x. I also considered "var" and "mem". >> (The other fun style question, which is a lot less minor, is whether >> ASSIGN_ONCE should be (src,dst) as above, or (dst,src) like = and >> <string.h>.) > I tend to prefer dst, src, but Linus used src, dst in his proposal - > so I used that. The question is, does Linus actually care (hey, Linus, do you?), or was that just a thoughtless part of a discussion about semantics? Because if you prefer it too, there are arguments... There are plenty of "store" operations with (src, dst) arguments, because the focus is on the value being stored, so it comes first. But the name "assign" almost always refers to the ":=" operation, with the focus more on the destination. (Now you have me thinking about German grammar and how the destination can be identified by the dative "dem". But even though German depends on word order less than English, normally the dative comes first.) -- To unsubscribe from this list: send the line "unsubscribe linux-arch" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html