Op 20-06-13 13:55, Ingo Molnar schreef: > * Maarten Lankhorst <maarten.lankhorst@xxxxxxxxxxxxx> wrote: > >> Changes since RFC patch v1: >> - Updated to use atomic_long instead of atomic, since the reservation_id was a long. >> - added mutex_reserve_lock_slow and mutex_reserve_lock_intr_slow >> - removed mutex_locked_set_reservation_id (or w/e it was called) >> Changes since RFC patch v2: >> - remove use of __mutex_lock_retval_arg, add warnings when using wrong combination of >> mutex_(,reserve_)lock/unlock. >> Changes since v1: >> - Add __always_inline to __mutex_lock_common, otherwise reservation paths can be >> triggered from normal locks, because __builtin_constant_p might evaluate to false >> for the constant 0 in that case. Tests for this have been added in the next patch. >> - Updated documentation slightly. >> Changes since v2: >> - Renamed everything to ww_mutex. (mlankhorst) >> - Added ww_acquire_ctx and ww_class. (mlankhorst) >> - Added a lot of checks for wrong api usage. (mlankhorst) >> - Documentation updates. (danvet) >> Changes since v3: >> - Small documentation fixes (robclark) >> - Memory barrier fix (danvet) >> Changes since v4: >> - Remove ww_mutex_unlock_single and ww_mutex_lock_single. >> - Rename ww_mutex_trylock_single to ww_mutex_trylock. >> - Remove separate implementations of ww_mutex_lock_slow*, normal >> functions can be used. Inline versions still exist for extra >> debugging. >> - Cleanup unneeded memory barriers, add comment to the remaining >> smp_mb(). > That's not a proper changelog. It should be a short description of what it > does, possibly referring to the new Documentation/ww-mutex-design.txt file > for more details. Well they've helped me with some of the changes and contributed some code and/or fixes, but if acked-by is preferred I'll use that.. >> Signed-off-by: Maarten Lankhorst <maarten.lankhorst@xxxxxxxxxxxxx> >> Signed-off-by: Daniel Vetter <daniel.vetter@xxxxxxxx> >> Signed-off-by: Rob Clark <robdclark@xxxxxxxxx> > That's not a valid signoff chain: the last signoff in the chain is the > person sending me the patch. The first signoff is the person who wrote the > patch. The other two gents should be Acked-by I suspect? > I guess so. -- To unsubscribe from this list: send the line "unsubscribe linux-arch" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html