On Thu, 7 Feb 2013 15:57:32 +0900, Alexandre Courbot <acourbot@xxxxxxxxxx> wrote: > On Wed, Feb 6, 2013 at 2:53 AM, Linus Walleij <linus.walleij@xxxxxxxxxx> wrote: > > On Sat, Feb 2, 2013 at 5:29 PM, Alexandre Courbot <acourbot@xxxxxxxxxx> wrote: > >> +/** > >> + * Convert a GPIO number to its descriptor > >> + */ > >> +static struct gpio_desc *gpio_to_desc(unsigned gpio) > >> +{ > >> + if (WARN(!gpio_is_valid(gpio), "invalid GPIO %d\n", gpio)) > >> + return NULL; > > > > Don't we want to return ERR_PTR(-EINVAL); here? > > > > Then you can use IS_ERR() on the pointers later. > > > > This is the approach taken by the external API for clk > > and pins. > > Yes, that completely makes sense. > No, it does not. The ERR_PTR()/IS_ERR() is a horrible pattern for code readability because it breaks the expectations that programmers have for what is and is not a bad pointer. There are decades of history where the test for a bad pointer is 'if (!ptr)'. Not only does ERR_PTR make make that test not work, but the compiler won't tell you when you get it wrong. There are places where ERR_PTR makes sense. Particularly when communicating with userspace where error codes have very specific meanings, but I don't want it in the GPIO subsystem. g. -- To unsubscribe from this list: send the line "unsubscribe linux-arch" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html