H. Peter Anvin wrote:
On 04/25/2012 04:26 AM, Konstantin Khlebnikov wrote:
Sometimes we want to check some expressions correctness in compile-time without
generating extra code. "(void)(e)" does not work if expression has side-effects.
This patch introduces macro unused_expression() which helps in this situation.
Cast to "long" required because sizeof does not work for bit-fields.
Signed-off-by: Konstantin Khlebnikov<khlebnikov@xxxxxxxxxx>
---
include/linux/compiler.h | 2 ++
1 file changed, 2 insertions(+)
diff --git a/include/linux/compiler.h b/include/linux/compiler.h
index 923d093..46fbda3 100644
--- a/include/linux/compiler.h
+++ b/include/linux/compiler.h
@@ -310,4 +310,6 @@ void ftrace_likely_update(struct ftrace_branch_data *f, int val, int expect);
*/
#define ACCESS_ONCE(x) (*(volatile typeof(x) *)&(x))
+#define unused_expression(e) ((void)(sizeof((__force long)(e))))
+
OK, bikeshedding a bit:
"unused_expression()" doesn't sound like something that inhibits side
effects, especially since "unused" applied to an argument or variable
means "don't make a fuss over this not being used."
-hpa
Ok, in v2 I'll rename it into BUILD_BUG_ON_INVALID()
--
To unsubscribe from this list: send the line "unsubscribe linux-arch" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html