Re: [PATCH 4/7] ARM: oprofile: Move non-ARM code into separate init/exit

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On 06.10.10 14:23:17, Grant Likely wrote:
> >> diff --git a/drivers/oprofile/oprof.c b/drivers/oprofile/oprof.c
> >> index b336cd9..76d97a5 100644
> >> --- a/drivers/oprofile/oprof.c
> >> +++ b/drivers/oprofile/oprof.c
> >> @@ -252,6 +252,8 @@ static int __init oprofile_init(void)
> >>  {
> >>       int err;
> >>
> >> +     memset(&oprofile_ops, 0, sizeof(struct oprofile_operations));
> >> +
> >
> > Yes, this looks much better. Thanks Paul.
> 
> oprofile_ops is allocated in bss and so is already zeroed.  No need to
> do it explicitly.

Before oprofile_arch_init() it isn't necessarily needed, but we should
definitely add it before oprofile_timer_init(). For code readability I
would rather tend to let the first in too.

-Robert

-- 
Advanced Micro Devices, Inc.
Operating System Research Center

--
To unsubscribe from this list: send the line "unsubscribe linux-arch" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html


[Index of Archives]     [Linux Kernel]     [Kernel Newbies]     [x86 Platform Driver]     [Netdev]     [Linux Wireless]     [Netfilter]     [Bugtraq]     [Linux Filesystems]     [Yosemite Discussion]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Samba]     [Device Mapper]

  Powered by Linux