Re: [PATCH] arm: rename CLOCK_TICK_RATE to ARM_TICK_RATE

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Tuesday 12 May 2009, Arnd Bergmann wrote:
> Most of the users of CLOCK_TICK_RATE in the kernel outside
> of ARM assume that it refers to the i8253 base frequency
> of 1.193182 Mhz, while in ARM it actually is the clock
> frequency of the timer.
> 
> By renaming it to ARM_TICK_RATE for all arm specific
> device drivers, we can hopefully reduce the amount
> of confusion slightly.

My patch was missing one important change to make this
a nonintrusive change:

--- a/arch/arm/include/asm/timex.h
+++ b/arch/arm/include/asm/timex.h
@@ -14,6 +14,8 @@
 
 #include <mach/timex.h>
 
+#define CLOCK_TICK_RATE ARM_TICK_RATE
+
 typedef unsigned long cycles_t;
 
 static inline cycles_t get_cycles (void)

	Arnd <><
--
To unsubscribe from this list: send the line "unsubscribe linux-arch" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html

[Index of Archives]     [Linux Kernel]     [Kernel Newbies]     [x86 Platform Driver]     [Netdev]     [Linux Wireless]     [Netfilter]     [Bugtraq]     [Linux Filesystems]     [Yosemite Discussion]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Samba]     [Device Mapper]

  Powered by Linux