Re: [PATCH 2/11] x86: convert to generic helpers for IPI function calls

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Wed, Apr 23 2008, Nick Piggin wrote:
> On Tue, Apr 22, 2008 at 12:50:30PM -0700, Linus Torvalds wrote:
> > 
> > 
> > On Tue, 22 Apr 2008, Ingo Molnar wrote:
> > > 
> > > ok. In which case the reschedule vector could be consolidated into that 
> > > as well (it's just a special single-CPU call). Then there would be no 
> > > new vector allocations needed at all, just the renaming of 
> > > RESCHEDULE_VECTOR to something more generic.
> > 
> > Yes.
> > 
> > Btw, don't get me wrong - I'm not against multiple vectors per se. I just 
> > wonder if there is any real reason for the code duplication. 
> > 
> > And there certainly *can* be tons of valid reasons for it. For example, 
> > some of the LAPIC can only have something like two pending interrupts per 
> > vector, and after that IPI's would get lost.
> > 
> > However, since the queuing is actually done with the data structures, I 
> > don't think it matters for the IPI's - they don't need any hardware 
> > queuing at all, afaik, since even if two IPI's would be merged into one 
> > (due to lack of hw queueing) the IPI handling code still has its list of 
> > events, so it doesn't matter.
> > 
> > And performance can be a valid reason ("too expensive to check the shared 
> > queue if we only have per-cpu events"), although I$ issues can cause that 
> > argument to go both ways.
> > 
> > I was also wondering whether there are deadlock issues (ie one type of IPI 
> > has to complete even if a lock is held for the other type). 
> > 
> > So I don't dislike the patch per se, I just wanted to understand _why_ the 
> > IPI's wanted separate vectors.
> 
> The "too expensive to check the shared queue" is one aspect of it. The
> shared queue need not have events *for us* (at least, unless Jens has
> changed the implementation a bit) but it can still have events that we
> would need to check through.

That is still the case, the loop works the same way still.

To answer Linus' question on why it was done the way it was - the
thought of sharing the IPI just didn't occur to me. For performance
reasons I'd like to keep the current setup, but it's certainly a viable
alternative for archs with limited number of IPIs available (like the
mips case that Ralf has disclosed).

-- 
Jens Axboe

--
To unsubscribe from this list: send the line "unsubscribe linux-arch" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html

[Index of Archives]     [Linux Kernel]     [Kernel Newbies]     [x86 Platform Driver]     [Netdev]     [Linux Wireless]     [Netfilter]     [Bugtraq]     [Linux Filesystems]     [Yosemite Discussion]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Samba]     [Device Mapper]

  Powered by Linux