Application won't compile

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


I downloaded an application (mfs-tools) which I am trying to compile on my
Debian "Lenny" system, but the make is failing with the following errors:

gcc -DHAVE_CONFIG_H -I. -I../include -I../include    -g -O2 -MT
readwrite.o -MD -MP -MF .deps/readwrite.Tpo -c -o readwrite.o readwrite.c
readwrite.c: In function 'tivo_partition_read':
readwrite.c:146: error: 'off64_t' undeclared (first use in this function)
readwrite.c:146: error: (Each undeclared identifier is reported only once
readwrite.c:146: error: for each function it appears in.)
readwrite.c:146: error: expected ')' before 'sector'
readwrite.c:146: error: expected ')' before 'sector'
readwrite.c: In function 'tivo_partition_write':
readwrite.c:261: error: 'off64_t' undeclared (first use in this function)
readwrite.c:261: error: expected ')' before 'sector'
readwrite.c:261: error: expected ')' before 'sector'
make[1]: *** [readwrite.o] Error 1
make[1]: Leaving directory `/downloads/software/mfstools-src/lib'
make: *** [all-recursive] Error 1

I've searched for the error, and I found some background information, but no
clear suggestions on how to resolve the issue.  I tried setting the


and then running the configure with

./configure --enable-debug

but I still get the same error.  Any ideas?

To unsubscribe from this list: send the line "unsubscribe linux-apps" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at

[Linux Kernel]     [Linux Laptop]     [Kernel Newbies]     [Share Photos]     [Security]     [Netfilter]     [Bugtraq]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Samba]     [Device Mapper]

  Powered by Linux