On 9/7/2023 8:37 AM, Mickaël Salaün wrote: > On Mon, Aug 28, 2023 at 12:57:54PM -0700, Casey Schaufler wrote: >> Create a system call lsm_get_self_attr() to provide the security >> module maintained attributes of the current process. >> Create a system call lsm_set_self_attr() to set a security >> module maintained attribute of the current process. >> Historically these attributes have been exposed to user space via >> entries in procfs under /proc/self/attr. >> >> The attribute value is provided in a lsm_ctx structure. The structure >> identifies the size of the attribute, and the attribute value. The format >> of the attribute value is defined by the security module. A flags field >> is included for LSM specific information. It is currently unused and must >> be 0. The total size of the data, including the lsm_ctx structure and any >> padding, is maintained as well. >> >> struct lsm_ctx { >> __u64 id; >> __u64 flags; >> __u64 len; >> __u64 ctx_len; >> __u8 ctx[]; >> }; >> >> Two new LSM hooks are used to interface with the LSMs. >> security_getselfattr() collects the lsm_ctx values from the >> LSMs that support the hook, accounting for space requirements. >> security_setselfattr() identifies which LSM the attribute is >> intended for and passes it along. >> >> Signed-off-by: Casey Schaufler <casey@xxxxxxxxxxxxxxxx> >> Reviewed-by: Kees Cook <keescook@xxxxxxxxxxxx> >> Reviewed-by: Serge Hallyn <serge@xxxxxxxxxx> >> Reviewed-by: John Johansen <john.johansen@xxxxxxxxxxxxx> >> --- >> Documentation/userspace-api/lsm.rst | 70 +++++++++++++ >> include/linux/lsm_hook_defs.h | 4 + >> include/linux/lsm_hooks.h | 1 + >> include/linux/security.h | 19 ++++ >> include/linux/syscalls.h | 5 + >> include/uapi/linux/lsm.h | 36 +++++++ >> kernel/sys_ni.c | 2 + >> security/Makefile | 1 + >> security/lsm_syscalls.c | 57 +++++++++++ >> security/security.c | 146 ++++++++++++++++++++++++++++ >> 10 files changed, 341 insertions(+) >> create mode 100644 Documentation/userspace-api/lsm.rst >> create mode 100644 security/lsm_syscalls.c >> >> +/** >> + * security_getselfattr - Read an LSM attribute of the current process. >> + * @attr: which attribute to return >> + * @uctx: the user-space destination for the information, or NULL >> + * @size: pointer to the size of space available to receive the data >> + * @flags: special handling options. LSM_FLAG_SINGLE indicates that only >> + * attributes associated with the LSM identified in the passed @ctx be >> + * reported. >> + * >> + * A NULL value for @uctx can be used to get both the number of attributes >> + * and the size of the data. >> + * >> + * Returns the number of attributes found on success, negative value >> + * on error. @size is reset to the total size of the data. >> + * If @size is insufficient to contain the data -E2BIG is returned. >> + */ >> +int security_getselfattr(unsigned int attr, struct lsm_ctx __user *uctx, >> + size_t __user *size, u32 flags) >> +{ >> + struct security_hook_list *hp; >> + struct lsm_ctx lctx = { .id = LSM_ID_UNDEF, }; >> + u8 __user *base = (u8 __user *)uctx; >> + size_t total = 0; >> + size_t entrysize; >> + size_t left; >> + bool toobig = false; >> + bool single = false; > Much easier to read with these booleans. > >> + int count = 0; >> + int rc; >> + >> + if (attr == LSM_ATTR_UNDEF) >> + return -EINVAL; >> + if (size == NULL) >> + return -EINVAL; >> + if (get_user(left, size)) >> + return -EFAULT; >> + >> + if (flags) { >> + /* >> + * Only flag supported is LSM_FLAG_SINGLE >> + */ >> + if (flags & LSM_FLAG_SINGLE) >> + return -EINVAL; >> + if (uctx && >> + copy_struct_from_user(&lctx, sizeof(lctx), uctx, left)) > Again, I'm not sure is copy_struct_from_user() should be used here > because it checks that the user space structures ends with zeros, which > is inconsistent with the case without LSM_FLAG_SINGLE. Anyway, this code > should at least properly handle the copy_struct_from_user() error codes > which includes EFAULT *and* E2BIG. Further testing makes your point. The checking in copy_struct_from_user() is really annoying. I'm going to fix this. > >> + return -EFAULT; >> + /* >> + * If the LSM ID isn't specified it is an error. >> + */ >> + if (lctx.id == LSM_ID_UNDEF) >> + return -EINVAL; >> + single = true; >> + } >> + >> + /* >> + * In the usual case gather all the data from the LSMs. >> + * In the single case only get the data from the LSM specified. >> + */ >> + hlist_for_each_entry(hp, &security_hook_heads.getselfattr, list) { >> + if (single) { >> + if (count > 0) >> + break; >> + if (lctx.id != hp->lsmid->id) >> + continue; >> + } >> + entrysize = left; >> + if (base) >> + uctx = (struct lsm_ctx __user *)(base + total); >> + rc = hp->hook.getselfattr(attr, uctx, &entrysize, flags); >> + if (rc == -EOPNOTSUPP) { >> + rc = 0; > Not a big deal but with LSM_FLAG_SINGLE, if the selected LSM doesn't > implement this hook, this will uselessly loop over all LSMs. > I'd add: > > if (single) > /* Still try to write 0 as the total size for consistency. */ > break; I'm trying to keep LSM_FLAG_SINGLE from being a complete special case. Asking for an attribute that the specified LSM doesn't support is a programming error, so I'm not concerned about a trivial performance issue. > >> + continue; >> + } >> + if (rc == -E2BIG) { >> + toobig = true; >> + left = 0; >> + total += entrysize; > I'm not sure what is the desired behavior with LSM_FLAG_SINGLE in this > case but I'd add: > > if (single) > break; I'm shifting the control logic a bit. I think it'll look cleaner. > >> + continue; >> + } >> + if (rc < 0) >> + return rc; > I think this should be a break instead of the return rc for consistency > reasons. No one has ever accused me of being consistent. I believe in using return aggressively. > >> + >> + left -= entrysize; >> + total += entrysize; >> + count += rc; > You could simplify a bit by replacing the first single check with this > one: > > if (single) > break; As above, I think I'm making this clearer in v15. > >> + } >> + if (put_user(total, size)) >> + return -EFAULT; >> + if (toobig) >> + return -E2BIG; >> + if (count == 0) >> + return LSM_RET_DEFAULT(getselfattr); >> + return count; >> +} >> + > It would be nice to add a comment before all these three syscall > documentations to keep up-to-date the related user space documentation > in lsm_syscalls.c Good thinking. > >> +/** >> + * security_setselfattr - Set an LSM attribute on the current process. >> + * @attr: which attribute to set >> + * @uctx: the user-space source for the information >> + * @size: the size of the data >> + * @flags: reserved for future use, must be 0 >> + * >> + * Set an LSM attribute for the current process. The LSM, attribute >> + * and new value are included in @uctx. >> + * >> + * Returns 0 on success, -EINVAL if the input is inconsistent, -EFAULT >> + * if the user buffer is inaccessible or an LSM specific failure. >> + */ >> +int security_setselfattr(unsigned int attr, struct lsm_ctx __user *uctx, >> + size_t size, u32 flags) >> +{ >> + struct security_hook_list *hp; >> + struct lsm_ctx *lctx; >> + int rc = LSM_RET_DEFAULT(setselfattr); >> + >> + if (flags) >> + return -EINVAL; >> + if (size < sizeof(*lctx) || size > PAGE_SIZE) > I would be better to return -E2BIG if size > PAGE_SIZE, and update the > (two) documentations accordingly. > >> + return -EINVAL; >> + >> + lctx = kmalloc(size, GFP_KERNEL); >> + if (lctx == NULL) >> + return -ENOMEM; >> + >> + if (copy_from_user(lctx, uctx, size)) { >> + rc = -EFAULT; >> + goto free_out; >> + } >> + >> + if (size < lctx->len || size < lctx->ctx_len + sizeof(*lctx) || >> + lctx->len < lctx->ctx_len + sizeof(*lctx)) { >> + rc = -EINVAL; >> + goto free_out; >> + } >> + >> + hlist_for_each_entry(hp, &security_hook_heads.setselfattr, list) >> + if ((hp->lsmid->id) == lctx->id) { >> + rc = hp->hook.setselfattr(attr, lctx, size, flags); > There is no need (at least for now) to directly expose lctx->id nor > lctx->flags. It would be simpler to only pass lctx->ctx and > lctx->ctx_len to the hooks. No. Absolutely not. I dislike passing string/length pairs, especially when they are both contained in a structure. > >> + break; >> + } >> + >> +free_out: >> + kfree(lctx); >> + return rc; >> +} >> + >> /** >> * security_getprocattr() - Read an attribute for a task >> * @p: the task >> -- >> 2.41.0 >>