On Tue, Jan 11, 2022 at 10:51 AM Eric W. Biederman <ebiederm@xxxxxxxxxxxx> wrote: > > + while ((n == -ERESTARTSYS) && test_thread_flag(TIF_NOTIFY_SIGNAL)) { > + tracehook_notify_signal(); > + n = __kernel_write(file, addr, nr, &pos); > + } This reads horribly wrongly to me. That "tracehook_notify_signal()" thing *has* to be renamed before we have anything like this that otherwise looks like "this will just loop forever". I'm pretty sure we've discussed that "tracehook" thing before - the whole header file is misnamed, and most of the functions in theer are too. As an ugly alternative, open-code it, so that it's clear that "yup, that clears the TIF_NOTIFY_SIGNAL flag". Linus