Re: [PATCH v8 23/32] fanotify: Wrap object_fh inline space in a creator macro

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Mon 18-10-21 21:00:06, Gabriel Krisman Bertazi wrote:
> fanotify_error_event would duplicate this sequence of declarations that
> already exist elsewhere with a slight different size.  Create a helper
> macro to avoid code duplication.
> 
> Suggested-by: Jan Kara <jack@xxxxxxx>
> Signed-off-by: Gabriel Krisman Bertazi <krisman@xxxxxxxxxxxxx>
> 
> ---
> Among the suggestions, I think this is simpler because it avoids
> deep nesting the variable-sized attribute, which would have been hidden
> inside fee->ffe->object_fh.buf.

One nit from me as well :)

> +#define FANOTIFY_INLINE_FH(size)					\
> +struct {								\
> +	struct fanotify_fh object_fh;					\
> +	/* Space for object_fh.buf[] - access with fanotify_fh_buf() */	\
> +	unsigned char _inline_fh_buf[(size)];				\
> +}
> +

Can the macro perhaps take the name of the fanotify_fh member it creates?
Like:

#define FANOTIFY_INLINE_FH(name, size)

Harcoding _inline_fh_buf is fine since it isn't ever used directly but
hardcoding object_fh looks ugly to me. With that improved feel free to add:

Reviewed-by: Jan Kara <jack@xxxxxxx>

								Honza

-- 
Jan Kara <jack@xxxxxxxx>
SUSE Labs, CR



[Index of Archives]     [Linux USB Devel]     [Video for Linux]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]

  Powered by Linux