On 11/11/2014 08:45 AM, Jarkko Sakkinen wrote:
Rename chip->dev to chip->pdev to make it explicit that this not the character device but actually represents the platform device. Signed-off-by: Jarkko Sakkinen <jarkko.sakkinen@xxxxxxxxxxxxxxx>
diff --git a/drivers/char/tpm/tpm.h b/drivers/char/tpm/tpm.h index 69f4003..b3a7c76 100644 --- a/drivers/char/tpm/tpm.h +++ b/drivers/char/tpm/tpm.h @@ -98,7 +98,7 @@ struct tpm_vendor_specific { #define TPM_PPI_VERSION_LEN 3 struct tpm_chip { - struct device *dev; /* Device stuff */ + struct device *pdev; /* Device stuff */ const struct tpm_class_ops *ops; int dev_num; /* /dev/tpm# */
So this is the core requiring the renamings. I assume you got them all and none were hidden in #if's or so.
Reviewed-by: Stefan Berger <stefanb@xxxxxxxxxxxxxxxxxx> -- To unsubscribe from this list: send the line "unsubscribe linux-api" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html