On 21-02-03 12:31:00, Dan Williams wrote: > On Wed, Feb 3, 2021 at 10:16 AM Konrad Rzeszutek Wilk > <konrad.wilk@xxxxxxxxxx> wrote: > > > > On Wed, Feb 03, 2021 at 09:16:10AM -0800, Ben Widawsky wrote: > > > On 21-02-02 15:57:03, Dan Williams wrote: > > > > On Tue, Feb 2, 2021 at 3:51 PM Ben Widawsky <ben.widawsky@xxxxxxxxx> wrote: > > > > > > > > > > On 21-02-01 13:28:48, Konrad Rzeszutek Wilk wrote: > > > > > > On Fri, Jan 29, 2021 at 04:24:37PM -0800, Ben Widawsky wrote: > > > > > > > The Get Log command returns the actual log entries that are advertised > > > > > > > via the Get Supported Logs command (0400h). CXL device logs are selected > > > > > > > by UUID which is part of the CXL spec. Because the driver tries to > > > > > > > sanitize what is sent to hardware, there becomes a need to restrict the > > > > > > > types of logs which can be accessed by userspace. For example, the > > > > > > > vendor specific log might only be consumable by proprietary, or offline > > > > > > > applications, and therefore a good candidate for userspace. > > > > > > > > > > > > > > The current driver infrastructure does allow basic validation for all > > > > > > > commands, but doesn't inspect any of the payload data. Along with Get > > > > > > > Log support comes new infrastructure to add a hook for payload > > > > > > > validation. This infrastructure is used to filter out the CEL UUID, > > > > > > > which the userspace driver doesn't have business knowing, and taints on > > > > > > > invalid UUIDs being sent to hardware. > > > > > > > > > > > > Perhaps a better option is to reject invalid UUIDs? > > > > > > > > > > > > And if you really really want to use invalid UUIDs then: > > > > > > > > > > > > 1) Make that code wrapped in CONFIG_CXL_DEBUG_THIS_IS_GOING_TO..? > > > > > > > > > > > > 2) Wrap it with lockdown code so that you can't do this at all > > > > > > when in LOCKDOWN_INTEGRITY or such? > > > > > > > > > > > > > > > > The commit message needs update btw as CEL is allowed in the latest rev of the > > > > > patches. > > > > > > > > > > We could potentially combine this with the now added (in a branch) CONFIG_RAW > > > > > config option. Indeed I think that makes sense. Dan, thoughts? > > > > > > > > Yeah, unknown UUIDs blocking is the same risk as raw commands as a > > > > vendor can trigger any behavior they want. A "CONFIG_RAW depends on > > > > !CONFIG_INTEGRITY" policy sounds reasonable as well. > > > > > > What about LOCKDOWN_NONE though? I think we need something runtime for this. > > > > > > Can we summarize the CONFIG options here? > > > > > > CXL_MEM_INSECURE_DEBUG // no change > > > CXL_MEM_RAW_COMMANDS // if !security_locked_down(LOCKDOWN_NONE) > > > > > > bool cxl_unsafe() > > > > Would it be better if this inverted? Aka cxl_safe().. > > ? > > > { > > > #ifndef CXL_MEM_RAW_COMMANDS > > nit use IS_ENABLED() if this function lives in a C file, or provide > whole alternate static inline versions in a header gated by ifdefs. > I had done this independently since... but agreed. > > > return false; > > > #else > > > return !security_locked_down(LOCKDOWN_NONE); > > > > :thumbsup: > > > > (Naturally this would inverted if this was cxl_safe()). > > > > > > > #endif > > > } > > > > > > --- > > > > > > Did I get that right? > > > > :nods: > > Looks good which means it's time to bikeshed the naming. I'd call it > cxl_raw_allowed(). As "safety" isn't the only reason for blocking raw, > it's also to corral the userspace api. I.e. things like enforcing > security passphrase material through the Linux keys api. It actually got pushed into cxl_mem_raw_command_allowed() static bool cxl_mem_raw_command_allowed(u16 opcode) { int i; if (!IS_ENABLED(CONFIG_CXL_MEM_RAW_COMMANDS)) return false; if (security_locked_down(LOCKDOWN_NONE)) return false; if (raw_allow_all) return true; if (is_security_command(opcode)) return false; for (i = 0; i < ARRAY_SIZE(disabled_raw_commands); i++) if (disabled_raw_commands[i] == opcode) return false; return true; } That work for you?