On Thu, Oct 24, 2019 at 11:38:27PM +0200, Hans de Goede wrote: > Add a "cht_crystal_cove_pmic" cell to the cells for the Cherry Trail > variant of the Crystal Cove PMIC. Adding this cell enables / hooks-up > the new Cherry Trail Crystal Cove PMIC OpRegion driver. > The code below is fine, although same wondering about naming scheme for PWM / GPIO. Reviewed-by: Andy Shevchenko <andriy.shevchenko@xxxxxxxxxxxxxxx> > Signed-off-by: Hans de Goede <hdegoede@xxxxxxxxxx> > --- > drivers/mfd/intel_soc_pmic_crc.c | 3 +++ > 1 file changed, 3 insertions(+) > > diff --git a/drivers/mfd/intel_soc_pmic_crc.c b/drivers/mfd/intel_soc_pmic_crc.c > index ab09b8225b76..429efa1f8e55 100644 > --- a/drivers/mfd/intel_soc_pmic_crc.c > +++ b/drivers/mfd/intel_soc_pmic_crc.c > @@ -88,6 +88,9 @@ static struct mfd_cell crystal_cove_cht_dev[] = { > .num_resources = ARRAY_SIZE(gpio_resources), > .resources = gpio_resources, > }, > + { > + .name = "cht_crystal_cove_pmic", > + }, > { > .name = "crystal_cove_pwm", > }, > -- > 2.23.0 > -- With Best Regards, Andy Shevchenko