Hi Rafael, On Fri, May 31, 2019 at 11:17:10AM +0200, Rafael J. Wysocki wrote: > On Friday, May 10, 2019 12:09:26 PM CEST Sakari Ailus wrote: ... > > diff --git a/include/linux/device.h b/include/linux/device.h > > index e85264fb66161..2a459fd5b954a 100644 > > --- a/include/linux/device.h > > +++ b/include/linux/device.h > > @@ -245,6 +245,11 @@ enum probe_type { > > * @owner: The module owner. > > * @mod_name: Used for built-in modules. > > * @suppress_bind_attrs: Disables bind/unbind via sysfs. > > + * @probe_powered_off: The driver supports its probe function being called while > > + * the device is powered off, independently of the expected > > + * behaviour on combination of a given bus and firmware > > + * interface etc. The driver is responsible for powering the > > + * device on using runtime PM in such case. > > * @probe_type: Type of the probe (synchronous or asynchronous) to use. > > * @of_match_table: The open firmware table. > > * @acpi_match_table: The ACPI match table. > > @@ -282,6 +287,7 @@ struct device_driver { > > const char *mod_name; /* used for built-in modules */ > > > > bool suppress_bind_attrs; /* disables bind/unbind via sysfs */ > > + bool probe_powered_off; > > This is a bit of a misnomer IMO, because it is not just about devices that are completely off. > From the ACPI perspective that is about all devices not in D0, which may mean gated clocks > etc. > > I would call it probe_low_power or similar and analogously in patch [2/5], and apart from this > I have no objections against this series, but I would suggest to CC the next iteration of it > to Greg K-H and the LKML as it touches the driver core. Ack. I'll do that for v2. Thanks for the review! -- Regards, Sakari Ailus sakari.ailus@xxxxxxxxxxxxxxx