On Mon, Aug 21, 2017 at 04:41:38PM +0000, Kani, Toshimitsu wrote: > Putting to a single line leads to "line over 80 characters" warning > from checkpatch.pl. Would you still advice to do that? Yes, the 80 cols rule is not a hard one. Rather, it should be overridden by human good judgement, like making the code more readable. > strncmp() is fine without these, but it'd be prudent in case someone > decides to print these strings with printk(). Will do. Someone does already use them in printk(): + pr_err(PREFIX "Vendor \"%6.6s\" System \"%8.8s\" Revision 0x%x has a known ACPI BIOS problem.\n", + acpi_blacklist[i].oem_id, + acpi_blacklist[i].oem_table_id, + acpi_blacklist[i].oem_revision); > 'data' here is private to the caller. So, I do not think we need to > define the bits. Shall I change the name to 'driver_data' to make it > more explicit? You changed it to 'data'. It was a u32-used-as-boolean is_critical_error before. So you can just as well make it into flags and people can extend those flags if needed. A flag bit should be enough in most cases anyway. If they really need driver_data, then they can add a void * member. -- Regards/Gruss, Boris. Good mailing practices for 400: avoid top-posting and trim the reply. -- To unsubscribe from this list: send the line "unsubscribe linux-acpi" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html