On Wed, Apr 19, 2017 at 11:48 AM, Dmitry Frank <mail@xxxxxxxxxxxxxxx> wrote: > This flag forces device_id_scheme bit in the struct > acpi_video_device_attrib to be assumed even if not actually set, so a > better name for the global flag would be "force_device_id_scheme". > > Signed-off-by: Dmitry Frank <mail@xxxxxxxxxxxxxxx> > --- > drivers/acpi/acpi_video.c | 16 ++++++++++------ > 1 file changed, 10 insertions(+), 6 deletions(-) > > diff --git a/drivers/acpi/acpi_video.c b/drivers/acpi/acpi_video.c > index 9a607af971e7..cfd3bed57bed 100644 > --- a/drivers/acpi/acpi_video.c > +++ b/drivers/acpi/acpi_video.c > @@ -73,8 +73,12 @@ module_param(report_key_events, int, 0644); > MODULE_PARM_DESC(report_key_events, > "0: none, 1: output changes, 2: brightness changes, 3: all"); > > -static bool device_id_scheme = false; > -module_param(device_id_scheme, bool, 0444); > +/* > + * Whether the struct acpi_video_device_attrib::device_id_scheme bit should be > + * assumed even if not actually set. > + */ > +static bool force_device_id_scheme = false; > +module_param(force_device_id_scheme, bool, 0444); The concern here is that if somebody uses that module parameter with current (or previous) kernels, your change will break their setups. It is better to simply add a comment clarifying the meaning of this flag IMO. Thanks, Rafael -- To unsubscribe from this list: send the line "unsubscribe linux-acpi" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html