On Fri, 2016-09-09 at 20:40 +0200, Borislav Petkov wrote: > On Fri, Sep 09, 2016 at 06:26:17PM +0000, Moore, Robert wrote: > > Is this a big deal? > > We do this on purpose for AcpiExec, to make the screen output more readable. [] > What do you mean "big deal"? All other ACPI_INFO calls don't have a "\n" > at the end except this one. How does one "\n" make some output more > readable? Blank lines in logging/dmesg generally don't add value. I would prefer if the unnecessary double parentheses also were removed in these macro uses and ##__VA_ARGS__ was used instead. /* * Error reporting. Callers module and line number are inserted by AE_INFO, * the plist contains a set of parens to allow variable-length lists. * These macros are used for both the debug and non-debug versions of the code. */ #define ACPI_INFO(plist) acpi_info plist #define ACPI_WARNING(plist) acpi_warning plist #define ACPI_EXCEPTION(plist) acpi_exception plist #define ACPI_ERROR(plist) acpi_error plist #define ACPI_BIOS_WARNING(plist) acpi_bios_warning plist #define ACPI_BIOS_ERROR(plist) acpi_bios_error plist It would also be good if format/argument verification was done here and in the non-debug macro variants. #define ACPI_INFO(plist) #define ACPI_WARNING(plist) #define ACPI_EXCEPTION(plist) #define ACPI_ERROR(plist) #define ACPI_BIOS_WARNING(plist) #define ACPI_BIOS_ERROR(plist) -- To unsubscribe from this list: send the line "unsubscribe linux-acpi" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html