I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng Liu <chuansheng.liu@xxxxxxxxx> Signed-off-by: Baole Ni <baolex.ni@xxxxxxxxx> --- drivers/acpi/processor_idle.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/acpi/processor_idle.c b/drivers/acpi/processor_idle.c index 444e374..fbe3ccc 100644 --- a/drivers/acpi/processor_idle.c +++ b/drivers/acpi/processor_idle.c @@ -55,7 +55,7 @@ static int bm_check_disable __read_mostly; module_param(bm_check_disable, uint, 0000); static unsigned int latency_factor __read_mostly = 2; -module_param(latency_factor, uint, 0644); +module_param(latency_factor, uint, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH); static DEFINE_PER_CPU(struct cpuidle_device *, acpi_cpuidle_device); -- 2.9.2 -- To unsubscribe from this list: send the line "unsubscribe linux-acpi" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html